Toyota Nation Forum banner

1 - 10 of 10 Posts

·
Lost to follow up!
96 Camry Coupes
Joined
·
12,156 Posts
Discussion Starter #1
A few minutes ago I went to engage the cruise on my 3.5, the dash lite flashed and the cruise doesn't work anymore. Whats up with that...anybody know? Thanks in advance for any information on how to fix this!
 

·
Registered
1994 Toyota Camry
Joined
·
1,384 Posts
This happened to me once or twice, but after a while it started working by itself. I don't have a clue as to what it was though.
 

·
Lost to follow up!
96 Camry Coupes
Joined
·
12,156 Posts
Discussion Starter #4
Thanks for the replies...got me stumped too! Sure hope somebody can help us, I really need it to work!
 

·
Lost to follow up!
96 Camry Coupes
Joined
·
12,156 Posts
Discussion Starter #5
It fixed itself!! works now, don't know what the problem was or is.I wonder if this is a sign of a future problem?
 

·
Registered
Joined
·
2 Posts
According to Toyota's Camry repair manual, the main cruise light flashes five times when it goes into "auto cancel" cruise mode. This is a response to a failure of signal from speed sensors, actuators, or any other little thing that might come up. There should be a trouble code logged when this happens, but my ECU never seems to generate one.

I've had this issue for the last 150K with my 95 Avalon (out of 250K). I usually shut off the cruise, wait ten minutes, and try again. The cruise always works again after I park it and crank it up again.

I know - it's a dimwitted way to deal with the problem, but it only shows up every few weeks.
 

·
Moving Forward
Joined
·
3,144 Posts
Most common problem is the brake light switch at the brake pedal. Check to make sure your brake lights are working. This switch will not cause the the brake indicator light to come on. IF it is the switch none of your brake lights will be working.

My brother in law had this problem a couple of months ago. Sometimes this will cause your transmission safety switch to not operate correctly also.
 
1 - 10 of 10 Posts
Top