Toyota Nation Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
15 Posts
Discussion Starter #1
My 83 Celica GTS 5 speed is cutting out at around 3600rpm's. If I stay on the throttle it will continue to decelerate until I release and re-apply. If I disconnect the battery for a while it will run fine for around 200 miles then it starts again. I have done new positive terminal, new ground wire to battery, cap, rotor, wires, plugs, and a PCV valve to try and stop this to no success. I do not have a check engine light coming on. Can anyone help me on this? I stumped and I'm not getting any help in the Celica forum. Thanks in advance for any help.
 

·
Official TN Memburr
'88 4Runner
Joined
·
133 Posts
Is the fuel injection set up properly? Could be computer...if it has one. Sorry, I don't know the cars, and I don't rev my 884Runner's 22re over 3500rpm too often.

Good luck.

D'mon
:confused:
 

·
Registered
Joined
·
406 Posts
sounds like it may be a computer problem. My brother has a 93' mazda b2600i that di the exact thing. it would run at low RPM, but when you gave it alot of gas, it sputtered for about 5 seconds, then ram fine. eventually it did this until one day he was driving and it lost all power.:eek: ..... should i say no more than $500 for a remanufactured computer and labor time... :mad:
i hope your case is different, but that'd be my closest guess as to your problem.

-Adam-
 

·
Registered
Joined
·
15 Posts
Discussion Starter #4
:hammer: thanks guys, your input is greatly appreciated.
 
1 - 4 of 4 Posts
Top