Toyota Nation Forum banner
1 - 7 of 7 Posts

·
Iron Chef IV
Joined
·
730 Posts
Discussion Starter · #1 ·
I changed the blubs on the cluster on my 93, an everything was great, until they started to fall out. Slowly all of the blubs fell out into the cluster. I could take the cluster out and shake the blubs out and put them back into the holder and everything would be fine. I am using Slyania from AUtozone, can anyone give me some insight?
 

·
Iron Chef IV
Joined
·
730 Posts
Discussion Starter · #3 ·
They do click. What I did notice was the blubs were a little more diffcult to push in than the stock blubs. So what I am thinking is that the 194LLs are a little bigger than the stock ones and therefore is popping out. I know that a lot of people have used 194LLs with no problems, but getting 4 bad batches from Autozone seems a little unlikely.
 

·
Still confused...
95 camry coupe v6
Joined
·
2,305 Posts
weren't the stock bulbs in the gen3 models also soldered on?
 

·
Still confused...
95 camry coupe v6
Joined
·
2,305 Posts
I changed the blubs on the cluster on my 93
haha, no, he worked on his gen 3... he even said so =P
 

·
Iron Chef IV
Joined
·
730 Posts
Discussion Starter · #7 ·
My 93 weren't soldered on. It is the same system as on our 92 Previa. There are black (i think) knobs that you twist off and pull out. I should mention that the blubs for the idiot lights are the only ones that fall out, the one for the illuminations have not fallen out (they use the same blub).

I dont think you can solder the wires very easily based on the holder, but super glue ...
 
1 - 7 of 7 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top