Toyota Nation Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
23 Posts
Discussion Starter #1
2014.5 Toyota Camry SE JBL premium with NAV, intermittent radio issue acted up again. No sound throughout system, no sound on any input, also nav until car shut off and restarted, then everything works great. happen three time in one year. Went to an unnamed dealership. They tested it while still happening. Couldn't believe it..... they diagnosed as bad radio. They turned car off and all started working fine. Said they've never seen anything like it?

Ordered radio, was told it might take a week to receive it. Showed up after two days, made appt, dropped car off after hrs.

Waited for a call the next day. No call. Called dealership 30 minutes before it closed. Service adviser that took care of car was gone, person on phone has no idea if car is done. Found the keys, can't find a work order, invoice or anything. Says "you can pick up car if you like, but i have no idea if it's done." WTF???

Why would i pick it up only to find out it has not even been started on????

Told them to keep it overnight & call me first thing.

Next day, no call before noon. Called dealership, they say "yes, it's done." Sorry, meant to call....

Have family member pick car up. Took it for a ride..... NO NAV. Message says check SD card or see dealership. Can't see a card in the slot. My guess is it's still in the old radio. Hope they didn't loose it.:frown:

CAN'T ANYONE DO ANYTHING RIGHT THESE DAYS???????

Going back again tomorrow. Very unhappy with my dealership and will let the owner know.
 

·
Registered
Joined
·
838 Posts
Unfortunate but all to common. Most dealerships have such high turnover rates it's impossible to keep knowledgeable trustworthy staff. Social media is where it's at, hit them where it hurts if they don't make it right for you.
 

·
Go Bolts!
Joined
·
1,143 Posts
The new system should have come with a SD card. If they don't replace it ask to speak to the manager. If you are still unhappy call Toyota Customer Service and file a complaint. It's worked for me in the past. Perhaps you can convince them to give you the new map update for free when it comes out in the next few weeks for your inconvenience. Never hurts to ask.
 

·
Registered
Joined
·
23 Posts
Discussion Starter #5
So it was back to the Dealership this morning to address NAV that doesn't work and also my iPod input that stopped working. Waited around for an hour and they figured out the NAV issue. NAV's now working, but the iPod input is not working. They looked at fuses & all were good. They think the USB connector might be dead. They ordered the part and said they'll call me when it's in. Service advisor said if the new USB doesn't fix the problem, it might be in the radio. I asked if it was a new radio & he said "NO, remanufactured because the new ones are like 5 grand". This better get fixed soon!

Service Manager gave me his card with a note in the back for a free oil change. BIG DEAL!

Really starting to get pissed off.........
 

·
Registered
Joined
·
23 Posts
Discussion Starter #6
Appointment set for Friday. USB port is in. Parts dept called and said I can pick it up. I told them they are installing it! Any chance this will fix the problem? LOL.....

Radio acted up again yesterday. Something totally different this time....... Audio / Nav "beeps" when any button or item pressed unusually "loud"?
Then went out later with car and it was back to normal.

Might be time to talk to Customer Relations Manager at Dealership and Toyota's Customer Experience Center.
 

·
Registered
Joined
·
23 Posts
Discussion Starter #7
Everything's good, except for a big scratch in the console top, but I'm done with those guys........ I'll live with the scratch, because i'm worried that if I have them replace the console trim piece, they'll screw up something else.

The USB port and iPod is working. Keeping my fingers crossed that all these issues are finally taken care of.

I even figured out how to get the new iPhone text messages to show up and read by the radio. Not very hard once you find out where the setting is on the phone.
 

·
Registered
Joined
·
23 Posts
Discussion Starter #8
recent issues

Just noticed that the radio has shutdown or rebooted a couple times lately. It seems to only happen while listening to XM radio. Black screen with no sound, Toyota Logo, then it gets going within about ten seconds. Phone typically reconnects soon after that. Not sure if I even want to mention it to the Toyota Dealer, since I've already had a ton of problems with the radio / nav system.
 
1 - 8 of 8 Posts
Top