Toyota Nation Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
I am desperate for help. I have searched for hours online trying to find a solution and have tried most everything suggested as solutions to the issue. I have a 2002 Toyota Tundra SR5 with a V8 4WD. It has been over a year now and I am still having throttle issues. More times than not anymore the truck refuses to start but after a couple of attempts it will eventually turn over and stay running. Most of the time it does this with no throttle response. Also, while driving down the road (when I do have throttle) it will "hiccup" and I will lose throttle. I know that it is going into "limp" mode. Also, every great once in awhile everything will be ok. The check engine light goes off and the truck is perfect again. This does not happen often and never lasts more than 2 days. I am going CRAZY.
The truck has had the codes p0120 and p0121 for awhile now but has recently added codes p1125 and p1128 .
Our mechanic has replaced the O2 sensor (that was the first thing to go bad), both TPS sensors, TPS motor, checked all wires and fuzes, checked grounds, cleaned AIC and everything else that he could think of and is at a complete loss. Help would be greatly appreciated. Thank you in advance.
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
thank you but have already searched the forums there and tried their possible solutions with no luck.
 

·
Registered
Joined
·
23 Posts
Check fuel pressure at the rail and replace or check the thermostat. Sounds like a closed loop problem. The engine might not be getting hot (185 degrees) fast enough before it goes into a closed loop condition. Also check the coolant temp sender's continuity for a steady graduated (ohms) reading as it gets hot. Sounds like the ECU is directing engine function based on inaccurate readings from the coolant temp (sensor or actual fluid temp) for some reason. But that's just my 2cents!
 
1 - 4 of 4 Posts
Top