Toyota Nation Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
1,133 Posts
Discussion Starter #1
a few months ago, my sienna 140k miles, started making grinding noise and a little bit of vibration on steering wheel around 35mph or higher only while turning left, going straight and turning right not as noticeable. there is no play at wheel, but upon putting the whole vehicle on lift and started driving at 60+ mph, there is noticeable vibration on passenger side spring.

when i spin the old hub after removed the axle, i do hear some clunking noise, after i installed the new wheel bearing, it does spin much more smooth and no noise.
i bought all parts from toyota stealership, $62 for wheel bearing, wheel bearing deflector $12, bearing snap ring $5, axle nut $6,

all these was done while the whole spindle knuckle assembly still on the vehicle, i only took off the 3 bolts at ball joint to remove the outer axle from the wheel hub. i did hear a loud bang once and have to use a 6 ft fence cheater pole applying about 60 to 80 lb ft of force before getting the wheel bearing moving.

here are some pictures i took while doing at my home garage, i am planning to do the other side soon.

http://i1287.photobucket.com/albums/a630/bronzemaxell/IMG_2786_zps5otbsqvm.jpg

http://i1287.photobucket.com/albums/a630/bronzemaxell/IMG_2785_zpsurqovi7j.jpg

http://i1287.photobucket.com/albums/a630/bronzemaxell/IMG_2784_zpsnhkcodvk.jpg

http://i1287.photobucket.com/albums/a630/bronzemaxell/IMG_2788_zpsp7al5iii.jpg

http://i1287.photobucket.com/albums/a630/bronzemaxell/IMG_2789_zpslocsljj8.jpg

http://i1287.photobucket.com/albums/a630/bronzemaxell/IMG_2790_zpsdq5e6ptq.jpg

http://i1287.photobucket.com/albums/a630/bronzemaxell/IMG_2791_zpsathtuamz.jpg

http://i1287.photobucket.com/albums/a630/bronzemaxell/IMG_2794_zps4rzdyjhr.jpg

http://i1287.photobucket.com/albums/a630/bronzemaxell/IMG_2797_zps6ljrc3xp.jpg

http://i1287.photobucket.com/albums/a630/bronzemaxell/IMG_2798_zpsp4qdpqgo.jpg

http://i1287.photobucket.com/albums/a630/bronzemaxell/IMG_2799_zpsnaorbxde.jpg

http://i1287.photobucket.com/albums/a630/bronzemaxell/IMG_2803_zpsocvztrus.jpg

http://i1287.photobucket.com/albums/a630/bronzemaxell/IMG_2806_zps3yhufkrc.jpg

http://i1287.photobucket.com/albums/a630/bronzemaxell/IMG_2807_zpsustjmcuk.jpg

http://i1287.photobucket.com/albums/a630/bronzemaxell/IMG_2810_zpsgotv3viu.jpg

http://i1287.photobucket.com/albums/a630/bronzemaxell/IMG_2815_zpsgozknepm.jpg

http://i1287.photobucket.com/albums/a630/bronzemaxell/IMG_2818_zpsmlqfss7k.jpg

http://i1287.photobucket.com/albums/a630/bronzemaxell/IMG_2820_zpseyhkj6gn.jpg

http://i1287.photobucket.com/albums/a630/bronzemaxell/IMG_2827_zps5fmdenrl.jpg

http://i1287.photobucket.com/albums/a630/bronzemaxell/IMG_2828_zpszfmwynrh.jpg

http://i1287.photobucket.com/albums/a630/bronzemaxell/IMG_2840_zpsgwmsty8o.jpg

http://i1287.photobucket.com/albums/a630/bronzemaxell/IMG_2842_zpshmexgs5m.jpg

http://i1287.photobucket.com/albums/a630/bronzemaxell/IMG_2843_zpsy0vzcez0.jpg

http://i1287.photobucket.com/albums/a630/bronzemaxell/IMG_2847_zpstweqbftx.jpg

http://i1287.photobucket.com/albums/a630/bronzemaxell/IMG_2849_zpsebyguxng.jpg

http://i1287.photobucket.com/albums/a630/bronzemaxell/IMG_2850_zps3oime2p4.jpg

http://i1287.photobucket.com/albums/a630/bronzemaxell/IMG_2851_zpscr7qnn5o.jpg

http://i1287.photobucket.com/albums/a630/bronzemaxell/IMG_2856_zpszekgyvgt.jpg

http://i1287.photobucket.com/albums/a630/bronzemaxell/IMG_2861_zpsnwhc7yew.jpg

http://i1287.photobucket.com/albums/a630/bronzemaxell/IMG_2863_zpsrgqis60e.jpg

http://i1287.photobucket.com/albums/a630/bronzemaxell/IMG_2868_zpsjpngersb.jpg

http://i1287.photobucket.com/albums/a630/bronzemaxell/IMG_2869_zps1eo89ghq.jpg

http://i1287.photobucket.com/albums/a630/bronzemaxell/IMG_2871_zpsn9i7pait.jpg
 

·
Registered
Joined
·
35 Posts
a few months ago, my sienna 140k miles, started making grinding noise and a little bit of vibration on steering wheel around 35mph or higher only while turning left, going straight and turning right not as noticeable. there is no play at wheel, but upon putting the whole vehicle on lift and started driving at 60+ mph, there is noticeable vibration on passenger side spring.

when i spin the old hub after removed the axle, i do hear some clunking noise, after i installed the new wheel bearing, it does spin much more smooth and no noise.
i bought all parts from toyota stealership, $62 for wheel bearing, wheel bearing deflector $12, bearing snap ring $5, axle nut $6,

all these was done while the whole spindle knuckle assembly still on the vehicle, i only took off the 3 bolts at ball joint to remove the outer axle from the wheel hub. i did hear a loud bang once and have to use a 6 ft fence cheater pole applying about 60 to 80 lb ft of force before getting the wheel bearing moving.

here are some pictures i took while doing at my home garage, i am planning to do the other side soon.




































































About to do this myself so fixed the pictures so readers don't have to go chasing down random links.
 

·
Super Moderator
Joined
·
12,806 Posts
Huh... Don't know how I missed adding this to the sticky, but I did now.
 

·
Registered
Joined
·
35 Posts
Huh... Don't know how I missed adding this to the sticky, but I did now.
I'm about to start on this today and since I write manuals for a living (cue groaning) I'll create another illustrated, more comprehensive step-by-step guide and post it up along with tools required. This picture list style left me in the dust around picture number 8. :frown:

Also, I'm not going to a shop to press the new bearing in as some people like. So it's all a do-it-at-home job.


Edit: Got it posted. See it here:

https://www.toyotanation.com/forum/274-sienna-2nd-generation-2004-2010/1655954-step-step-changing-front-bearings-2nd-generation-sienna.html
 
1 - 5 of 5 Posts
Top