Toyota Nation Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
I took my 1995 3.4L v6 Tacoma to Canadian Tire. My Truck has always got 450km a tank from Full to Empty. But since last Oct. it dropped to 400 then 350, now 300-320 and holding around there. They checked the codes and got P01300, checked everything out and said it is my Igniter. Well I just wanted another opinion on this as a igniter is expensive and never returnable.
What do you think????
 

·
Registered
Joined
·
937 Posts
I think a bad igniter would cause an extremely poor running condition or just a flat out no start. Its obviously throwing that code for a reason so there still may be a problem with the igniter but i doubt its the cause of your poor fuel mileage, especially if it seems to be running ok (not misfiring). A drop in MPG is usually due to oxygen sensor readings or mass air flow sensor readings that are a little bit off due to age, mileage, or contaminants.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #3
Okay, sounds right. My truck does have a slight stutter during idle, and also when I try quick take offs. So that explains the igniter code then. Well so you are suggesting I try a new O2 sensor. Which do I switch before or after Cat ?
Thanks for your help by the way...
 

·
Registered
Joined
·
19 Posts
running issue

Igniter I would think wouldn't let the truck run at all, but who knows. My 98 taco had 215,000 miles on the original o2 sensors and cat. Ran like crap one day. Went from 300 miles to a tank of fuel then 275 miles then 250 mile and stayed there until I changed the cat and o2 sensors. Front o2 sensor was about to fall out of the pipe cause the nuts rusted off. The funny thing was no check engine light. After replacement the mileage shot up to around 290 mile to a tank and then eventually lately some where around 315 miles to a tank with all freeway driving. Good old truck 224,000 mies as of today and runs like a champ! Good Luck!
 

·
C-5 Mekinik
Joined
·
237 Posts
If you are gettign an ignitor code and the trucks is not runnign smoothly, change the ignitor and see if your stutter goes away and mileage improves. Do this before throwing money at other possibilities until you eliminate soemthing that the ECM is throwing a code for. If you are not getting a good proper spark it will still run, but mileage will suffer.
 
1 - 6 of 6 Posts
Top