Toyota Nation Forum banner

21 - 40 of 47 Posts

·
Inveterate Tinkerer
2014 Avalon Limited
Joined
·
1,085 Posts
When I press Ev, Eco or Sport nothing happens , the instrument panel only shows Eco
The message center of your Hybrid is different from my gas model and my display is different from the XLE but....when in ECO mode my message center gets a green bar and eco is shown at the top. When in NORM mode nothing is displayed, when in SPORT mode the display gets a red bar, "Sport Mode" is shown for a few seconds on the display and the word 'sport' displays near the headlight on icon.

Check your display again and see if there's a color bar or "sport" is displayed someplace when in that mode. Start button needs to be pressed twice or start (whatever it's called with hybrids) the car.

Another thought, check the Avalon Hybrid forum to see if you can get a more definitive answer.

Cheers!
 

·
Registered
2013 XLE Touring V6
Joined
·
79 Posts
When I press Ev, Eco or Sport nothing happens , the instrument panel only shows Eco
Although that photo is for a Hybrid (I think), for me there is a SPORT light which appears adjacent to the ECO light's location. Additionally, the green bar above the odometer changes to red when in sport. I've got a '13 XLE Touring so your display may be different.

I assume that on a Hybrid, these buttons basically do the same as on my Touring. Increase throttle response and tighten the electric steering to the SPORT side, and decrease them going towards the ECO side (along with the HVAC decrease when in ECO).

[EDIT] +1 on Gadjetjq in previous post (I was typing as he was posting)
 

·
Registered
2013 Avalon Hybrid
Joined
·
79 Posts
Although that photo is for a Hybrid (I think), for me there is a SPORT light which appears adjacent to the ECO light's location. Additionally, the green bar above the odometer changes to red when in sport. I've got a '13 XLE Touring so your display may be different.

I assume that on a Hybrid, these buttons basically do the same as on my Touring. Increase throttle response and tighten the electric steering to the SPORT side, and decrease them going towards the ECO side (along with the HVAC decrease when in ECO).

[EDIT] +1 on Gadjetjq in previous post (I was typing as he was posting)

Mine is the 2013 Hybrid

But as I said before pressing any of the 3 does nothing. Nor does it show any changes on the odometer .
 

·
Registered
Toyota Avalon
Joined
·
75 Posts
I like the responsiveness of Sport mode, but prefer the lighter steering in Normal mode. It really helped to have light steering after my heart attack when everything was an effort!!!!
When I'm on the interstate I always hit Sport because the tighter steering feels a lot more secure, and passing becomes pretty instantaneous.
Eco mode makes the Avalon horribly slow and unresponsive, and I never use it. That mode must be for post heart attack victims who didn't make it :(
 

·
Inveterate Tinkerer
2014 Avalon Limited
Joined
·
1,085 Posts
Mine is the 2013 Hybrid

But as I said before pressing any of the 3 does nothing. Nor does it show any changes on the odometer .
So, just for grins n giggles I checked out your owner's manual and did a little screen grab. You 'should' be seeing Eco and Sport modes indicated as shown (when ignition is on and in those modes of course).
 

Attachments

·
Inveterate Tinkerer
2014 Avalon Limited
Joined
·
1,085 Posts
Mine is the 2013 Hybrid

But as I said before pressing any of the 3 does nothing. Nor does it show any changes on the odometer .
So, just for grins n giggles I checked out your owner's manual and did a little screen grab. You 'should' be seeing Eco and Sport modes indicated as shown (when ignition is on and in those modes of course).
 

Attachments

·
Registered
2013 Avalon Hybrid
Joined
·
79 Posts
So, just for grins n giggles I checked out your owner's manual and did a little screen grab. You 'should' be seeing Eco and Sport modes indicated as shown (when ignition is on and in those modes of course).
Not my instrument cluster

Sent from my SM-N960U using Tapatalk
 

·
Registered
2013 Avalon Hybrid
Joined
·
79 Posts
This is mine but I can press Sport,Eco and Ev all day long and it does nothing and sure doesn't show in that cluster


Sent from my SM-N960U using Tapatalk
 

·
Registered
2013 XLE Touring V6
Joined
·
79 Posts
I can press Sport,Eco and Ev all day long and it does nothing and sure doesn't show in that cluster
That being the case, could it be as simple as the plug for that bank of switches is disconnected? You can easily access it by pulling up on your cupholder and looking under the drive mode switches from the passenger side. Just a thought.

BTW, for your photo, is your Avalon turned ON and "running"? I don't have the Hybrid, but I don't think all of those would be lit when in the running position unless an awful lot of things were wrong.
 

·
Registered
2013 Avalon Hybrid
Joined
·
79 Posts
Those lights all go out , I just snapped the picture before it was done starting

Sent from my SM-N960U using Tapatalk
 

·
Registered
2013 Avalon Hybrid
Joined
·
79 Posts
Well I guess it fell into the "Avalon 4th Generation (2013-2018)"

Sent from my SM-N960U using Tapatalk
 

·
Registered
2013 Avalon Hybrid
Joined
·
79 Posts
It does, but hybrids are peculiar animals, not everything operates the same way as on conventional brethren.

Help me out here, in what thread did the OP post this question.


I still have my problem nothing has worked out for the best , in regards to this matter.
 

·
Registered
2014 Avalon Hybrid,
Joined
·
496 Posts
The Miz: in a n attempt to clarify model info, there is a separate area for hybrid models. It's a lonely place over there, but ukrkoz is right: your question is hybrid specific, and you should post your question there.

There are many areas where model info overlap (body, lighting, seats, etc. etc.) , and posting here will always get you a quicker answer, as there are more V6 members than Hybrid.

I'll take a look at my 2014 dash cluster later today (my wife is returning from a 3-day road trip). I'm not sure if the 2014 cluster is different than the 2013, though.
 

·
Registered
2013 Avalon Hybrid
Joined
·
79 Posts
The Miz: in a n attempt to clarify model info, there is a separate area for hybrid models. It's a lonely place over there, but ukrkoz is right: your question is hybrid specific, and you should post your question there.

There are many areas where model info overlap (body, lighting, seats, etc. etc.) , and posting here will always get you a quicker answer, as there are more V6 members than Hybrid.

I'll take a look at my 2014 dash cluster later today (my wife is returning from a 3-day road trip). I'm not sure if the 2014 cluster is different than the 2013, though.


I understand where the icon should show up on the dash cluster .

I guess the problem is I don't know how to in-gauge the controls or they just don't work.

I actually googled the problem and it lead to this thread.
When i posted to this thread I had no idea it wasn't in the Avalon Hybrid forum , that is why I asked before it was moved yesterday where was it.
 

·
Registered
Joined
·
292 Posts
I use Normal mode 99% of the time, Eco mode 0%, EV mode 0% and Sport mode only when I need an extra burst in speed to merge in heavy traffic. With both this Avalon hybrid and my no longer owned 2010 Prius, I found that Eco mode just made the car sluggish to drive and had no effect on my fuel economy since I accelerate at the same rate and drive the same in both modes. I just drive the Avalon hybrid like any other car and don't hot rod or hypermile.
 

·
Registered
2013 Avalon Hybrid
Joined
·
79 Posts
I use Normal mode 99% of the time, Eco mode 0%, EV mode 0% and Sport mode only when I need an extra burst in speed to merge in heavy traffic. With both this Avalon hybrid and my no longer owned 2010 Prius, I found that Eco mode just made the car sluggish to drive and had no effect on my fuel economy since I accelerate at the same rate and drive the same in both modes. I just drive the Avalon hybrid like any other car and don't hot rod or hypermile.

I am just looking forward to the day I can try out the ECO, EV and SPORTS mode.
 

·
Registered
2014 Avalon Hybrid,
Joined
·
496 Posts
Are you near any Toyota dealerships? Used car dealers? You might be able to find a 2013 TAH to at least LOOK at, push buttons, etc, to establish that your eco/sport/EV switches are in fact non-functioning.
 

·
Registered
2013 Avalon Hybrid
Joined
·
79 Posts
Well the dealership seems to not be in any hurry on this , but they called today and told me I need to be moving to press those to engage them. I haven't tried this but will later today. Seems odd to me as I never found much info about this in the manuals
 
21 - 40 of 47 Posts
Top