Toyota Nation Forum banner

Electric Fan Confuzzlement

336 Views 9 Replies 5 Participants Last post by  93celicaconv
Hey everyone:)
I have a 1991 Corolla with 4AF carburettor engine. I have a problem where the fan doesn't turn on unless the fan switch (which is located near the thermostat) is unplugged. I thought that the problem was the fan switch, but today I was working on something unrelated and bumped a wire (pictured) next to the battery and the fan randomly started up. On looking closer, the box that the wires go into (pictured) is quite corroded making a dodgy connection. Clearly there is a problem here. Does anyone know what this thing is or how I could fix it (it looks like the insides of it are beyond repair)?
I am highly confused as to what this thing does.
Thanks in advance.
[email protected]

Attachments

  • Like
Reactions: Corrolla clone
1 - 4 of 4 Posts

· Registered
1991 Corolla AE92 4AF
Joined
·
14 Posts
Discussion Starter · #3 ·
You’ve mentioned components whose locations cover the entirety of your engine bay, and have also posted a highly zoomed-in picture of a single connector. Not sure what you’re trying to accomplish.
The components all happen to be on the same fan circuit. I am not an auto electrician, but I do have enough knowledge to know that this means that they all work together to get the fan turning despite the fact that they are not right next to each other.

As for the picture: I explained exactly where in the engine bay it is and I could take more pictures if necessary. I was hoping that someone would have had some experience with the problem that I am having.

As for what I am trying to accomplish: I am trying to find if anyone has had this problem and could give me advice on how to fix it based on their experience. If I bypassed the connector, the fan would run constantly, even when the engine is cold.
 

· Registered
1991 Corolla AE92 4AF
Joined
·
14 Posts
Discussion Starter · #5 ·
The switch that turns your fan on if your coolant temperature is getting high is a coolant temperature switch. I don't have information on where that switch is on a Corolla 4A-F engine, but on a Celica 4A-FE engine, that switch is at the bottom of the radiator. If you disconnect the wiring harness from that coolant temperature switch, the fan should turn on at high speed. If your coolant hasn't reached that elevated temperature, the switch will not open, causing the fan to turn on. In normal driving, the fan will not turn on as the car is moving and has air going through the radiator cooling the coolant. If the car is parked with the engine running, there is no air going through the radiator to cool the coolant, so it is normal after idling while parked for 10-20 minutes for the fan to start cycling on & off. If yours does this, you don't have a problem to solve.
Thanks for the reply.
My fan never turns on unless the harness is unplugged from the fan switch (even on a 40*C day in heavy traffic), so I am pretty sure there is a problem somewhere.
I am quite confused as to why the fan turns on when that pictured connecter is wiggled (even when the engine is cold and not running). Thus, I am thinking that there is a wiring problem there. The fan is always on if I bypass the connector (which is badly corroded), so I am not sure what could be done about that.
 

· Registered
1991 Corolla AE92 4AF
Joined
·
14 Posts
Discussion Starter · #9 ·
Thanks for the advice. I idled the car for a while today and the fan did turn on eventually, so I don't seem to have a problem there. I had never heard it turn on before, so I mistakenly thought it wasn't working.
I think the plug that makes the fan start up is probably for the air-conditioned spec models (the fan is always on when the air-conditioner is on, as far as I know). I don't have an air-conditioner in this car, so I think the corrosion in the plug is making allowing the wires to make contact, which turns the fan on.
The advice is much appreciated :)
 
1 - 4 of 4 Posts
Top