Toyota Nation Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
I have put a new engine into my camry but it cannot start without accelerating and also cannot do instant rev ups....It idles but I have notice the fuel seem to be running out faster than before.... Please help.. Thank you
 

·
short-throw dipstick
Joined
·
6,095 Posts
Hm, this is the opposite of what I've encountered before with swaps...I'd start by checking the throttle position sensor.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #3
OK but will it trigger a fault code on a scanner caused I have tried scanning and still no fault code....... Thank you
 

·
Moderator
Joined
·
7,750 Posts
Well, you have petrol leak somewhere. What you do by "accelerating" is you let more air into combustion chambers. Thus, should you have leaky injectors...or, bad fuel regulator...or, injectors stuck open...or, injectors harness issue... you are flooding engine.
Also, that explains why is appears to be gas guzzling, aye?
 

·
Registered
Joined
·
4 Posts
Discussion Starter #5
  1. OK... Thank you so much... I will do all my checks and see..
  2. I forgot to mention that when I switch the air cond on the engine losses power and cuts off...... I don't know...Thank you....
 

·
Registered
Joined
·
4 Posts
Discussion Starter #7
Thanks....I was doing some tests with a diagram I down loaded and confirmed that my vsv on the vaccumm hose is us. Please confirm if this will contribute... Thank you so much.....
 
1 - 8 of 8 Posts
Top