Toyota Nation Forum banner

1 - 3 of 3 Posts

·
Tina come get some ham
05 Sport 4X4
Joined
·
1,023 Posts
Discussion Starter #1
When I decelerate or coast down a hill several times now my engine hesitates. Quite noticably I might add. I had to change out one of my a/f sensors not long ago so that isn't the problem unless the other one needs to be changed as well. I run nothing less that 89 octane and either shell or chevron gas goes in the tank. My plugs have about 20k on them could that be an issue? Would a bad plug make is miss sometimes but not always. It never happens at WOT. Any suggestions? I have a scan guage and aren't throwing any codes. thanks folks
 

·
Hi-Miler
07 siver 4x2 Taco lo
Joined
·
308 Posts
i dont know what sensor you change.......... nor why

did you do any other work ?????

no less fuel octane would have no effect coasting down a hill
at all

im not sure you could notice a stutter
the engine is on trailing throttle then
usually it is


most notice a stutter come back on throttle
not just coasting down a hill

good luck
 

·
Tina come get some ham
05 Sport 4X4
Joined
·
1,023 Posts
Discussion Starter #3
i dont know what sensor you change.......... nor why

did you do any other work ?????

no less fuel octane would have no effect coasting down a hill
at all

im not sure you could notice a stutter
the engine is on trailing throttle then
usually it is


most notice a stutter come back on throttle
not just coasting down a hill

I was getting an error code for my 02 sensor is why I had to change it. A tsb. It's stuttering noticably and I don't have a cause. Maybe not so much coasting as much as just in the lower rpm range. 1.5-2k rpm.

good luck
 
1 - 3 of 3 Posts
Top