Toyota Nation Forum banner

21 - 26 of 26 Posts

·
Registered
Joined
·
11 Posts
Have the same issue with my cruise control. Northern Toyota in Prince George, BC blew me off twice, this is normal. Even told me not to use it if I felt it was unsafe, or I was using it improperly.

Between the CC and my front diff the truck's OK though.

Am I bitter? Nah
 

·
Registered
Joined
·
666 Posts
I have had no issues with mine what so ever. I've taken I80 out to roughly RT. 144 (little past lock haven) which is full of rolling hills and more towards the end there is a big hill. I've had cruise set @ 65 towing my trailer w/ an ATC 200x and a DR650 on it, plus a weekend's worth of camping supplies (coolers, riding gear, tent, grill, etc.) and only had it drop down to 4th to pull the hill @ speed.

That does sound weird that you guys experience this problem w/ the CC. I happen to love it, I just drove down to new jersey tonight (70mph once I hit the NJ Turnpike) and had no problems. Love the CC.
 

·
Registered
Joined
·
1,170 Posts
Doesn't the manual say not to use cruise control in hilly terrain? I almost never use it because it's stupid and over reacts causing it to downshift when it shouldn't need to. It works ok on the flats. Oh well. You can't have everything.
 

·
Registered
Joined
·
3 Posts
I am experiencing an issue with the cruise control on my 07 V6 Auto. It will maintain set speed fine most of the time, but occaisonally on hills it will accelerate as much as 10 mph over set speed when going UP a hill. This usually happens after the trans. downshifts. I know that if I waste my time going to the dealer I will get the "could not duplicate" BS. Has anyone experienced this or been able to get a fix?
 

·
Registered
Joined
·
3 Posts
I am experiencing an issue with the cruise control on my 07 V6 Auto. It will maintain set speed fine most of the time, but occaisonally on hills it will accelerate as much as 10 mph over set speed when going UP a hill. This usually happens after the trans. downshifts. I know that if I waste my time going to the dealer I will get the "could not duplicate" BS. Has anyone experienced this or been able to get a fix?

I had a 2012 and had no problems whatsoever. My 2016, however does the same thing. My buddy’s 2018 does the same thing. It pisses me off because I drive 4.5 hours one way to work and I will use about an 1/8 to a 1/4 tank more in fuel if u use my cruise control. I recently put a lift/levelling kit and bigger tires and it is even worse
 

·
My Other Truck
Joined
·
4,262 Posts
I had a 2012 and had no problems whatsoever. My 2016, however does the same thing. My buddy’s 2018 does the same thing. It pisses me off because I drive 4.5 hours one way to work and I will use about an 1/8 to a 1/4 tank more in fuel if u use my cruise control. I recently put a lift/levelling kit and bigger tires and it is even worse
Seriously?? You spend 9 hours every day driving to work & then back home? Holy crap, that must be some kind of a record.
If that's true, you really need to be driving something that returns much better fuel economy. Or relocate. Or change jobs.
Everything about this problem has already been discussed at length in this 12-year-old thread. Good luck.
 
21 - 26 of 26 Posts
Top