Toyota Nation Forum banner
1 - 6 of 6 Posts

·
jpspartan09
08 Tacoma
Joined
·
454 Posts
don't have a magnaflow, i have a cherry bomb extreme... but i noticed a slight gain in power; definitely not a loss?
 

·
Registered
'07 Tacoma DC,4X4
Joined
·
166 Posts
i believe that is a back pressure problem. i put on a 3in. flowmaster cat back system on my camaro ss (first mod done to it) and noticed a major decrease in power. i asked the mechanic next door where i worked and he told me that. he said to get a bigger mas airflow sensor and k&n filter that will let more air in the engine that the exhaust is letting out. it worked like he said, and the muffler got louder as well.

he told me (if i remember right and he told me this 9 years ago) the flowmaster exhaust system releases all the air in the cylinder when the exhaust valve opens due to it being a lot less restricted by the more flowing muffler , that release makes the amount of air still in the cylinder after the exhaust valve closes not have air still in it so the air that the intake valve lets in is not as much as before due to the release of the trapped air. (or back pressure) so there for less air in the cylinder less power. the way to get that back is to get more air in the engine . like i said i added a mass air sensor in the camaro, don't know the answer to the fix for the tacoma. hope this helps and remember i was told this 9 years ago so i hope i remember everything he said.
 

·
Completely Numb
TRD Sport
Joined
·
824 Posts
Any thoughts to pulling the neg cable off for 30 minutes. Help or hurt?

Never hurts, it'll basically just reset the truck. I did it when I installed my intake, and again when I installed my cat-back. So, the truck will just be re-adjusting to the new hardware. And if i'm crazy and flat out wrong, it's not like the truck won't start when you put it back on.
 
1 - 6 of 6 Posts
Top