Toyota Nation Forum banner

61 - 64 of 64 Posts

·
Registered
Joined
·
2 Posts
my 89 toy p/u when its cold out, 60 deg or below, below 40 deg, idle surge when I hit the brakes, let off brakes, goes to high idle, let it sit 10 mins, idles great, touch brakes and it does it again.
 

·
Registered
Joined
·
1 Posts
Alright guys need some help, got 92, 3.0 v6 new coil, fuel pump everything seems to be operating correctly, I can crank the truck, while cold it runs great, but after the motor gets warm or runs a while, whether idling or goin down the rd, it just cuts off and a couple fuses in the box in the cab on driver side are pretty warm, the truck had been under water and up above that box, is there a good chance the fuse box is no good any more and it's just Heating up due to corrosion ?
 

·
Registered
Joined
·
8 Posts
Hey guys,

I've just replaced my timing chain and guides, and everything that goes with it. One of the main goals was also to fix a slight oil leak right up the top of the timing case just above the water pump. Now, while the case was off, I made sure the section of head gasket that is free'd up was stuck to the head with gasket goo, then while I placed the timing case back on there was nothing that could possibly get through.
Left it for a few days to dry before getting everything back on and putting oil etc back in. Started her up, did the timing, and sure enough, the little son of a bitch of an oil leak is back in the same spot. Does anyone else have this problem with the 22r???? How do I fix it :/
 

·
Registered
Joined
·
55 Posts
I have a problem right now where engine timing is low and needs to be forwarded. Idle is low when not giving gas. But as mechanic turned the idle screw up half a turn, didn't fix the problem. Going to have him forward the engine timing. Problem started as he changed the engine timing to pass smog test.
 
61 - 64 of 64 Posts
Top