Toyota Nation Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter #1
Hey guys got a problem. Had a coolant leak so I fixed that, blead the system now the truck idles high about 1800 and pulses down to 1500 and then back up. Curious what you guys think it could be. Thanks.
 

·
Registered
Joined
·
318 Posts
Adjust your idle! The surging is when the brake is pressed right? If you adjust the idle the surge will go away...it did with mine.
 

·
YOTA Master
'93 2wd P/U
Joined
·
2,434 Posts
you still have air in the cooling system...

fill the radiator to the top and let it idle until the thermostat opens up, then top it up again.

It may help to elevated the front of the truck with ramps, or pull it up on a curb.
 

·
Registered
Joined
·
318 Posts
OK. How do I do that?
Do what?

If your talking about the idle then look at the throttle body and where the accelerator cable attaches to the butterfly assembly and all of that. You'll notice a screw thing that is facing upward. Turn it (don't remember which way) until the idle is set right. It is easy to spot.

It is very likely that the thermostat is stuck open. Causing a sensor that read the coolant (coolant temp sensor) and that in turn turns your idle down. I think that is how it works.

Anyway. I hope you are not asking how to fill up the radiator are you?
 

·
YOTA Master
'93 2wd P/U
Joined
·
2,434 Posts
The auxillary air valve on the bottom of your throttle acts like a thermaosta but backwards. When the engine is cold it opens up and allow air to bypass the throtle rincreasing the idle speed. As the engine warms up it gradually closes decreasing the idle speed until it at normal operating temperature.

If there is an air pocket trapped in the cooling system, it will not allow coolant to circualte through the auxillary air valve and the idle will stay high and your idle will surge

Bleed the cooling system
 

·
Registered
Joined
·
318 Posts
That seems more plausible...and why do you have a sig only on some posts?
 

·
Registered
Joined
·
397 Posts
sig's only appear for the first post per page of a thread.. so if you make another post it shouldn't show up
 

·
Registered
Joined
·
397 Posts
1 - 11 of 11 Posts
Top