Toyota Nation Forum banner

1 - 5 of 5 Posts

·
Registered
1998 toyota camry
Joined
·
33 Posts
Discussion Starter #1
hey guys, i got some 194 LEDs from www.automotiveled.com and after having them in for about 2 weeks they have started flickering. has anyone else noticed this with their LED setups? my friend thinks its because of the heat, but i think it's because the LEDs are cheap. what's the best source to use? i've heard good things about www.superbrightled.com

any thoughts or comments?
 

·
Beware of pigs
Little Pig
Joined
·
2,445 Posts
bigbird said:
aparently the flickering is caused by the very low amount of "power" the LEDs need to function, which fools the car into thinking there not on. the load resistor should do the trick.
No, I think those LEDs flickering are on their way out. I once bought ten 194 white inverted cone LEDs off ebay; sold 4, some soon flickered, one failed and was taken apart for its base, only about 2 remains. Goes on to say what crap they are. They're mostly used for license plate lights for their nice blue tone. ;)

I have a LED flashlight with six such LEDs, and half of them would start to blink really quick. That was resolved only by adding a small resistor in series to them.

OTOH some 74 white units and two 3157 20-LED units, also bought off ebay, are working much better. That said they didn't get used much.
 

·
Registered
1999 Camry LE
Joined
·
106 Posts
I bought some blue inverted LED bulbs off E-bay from some dude in China. I've had them in for about 2 months and they've been fine. I love them. LED's don't get hot, or as hot as a regular bulb, thats the benefit of an LED. I'll try to find the guys user name if you want to check his e-bay stuff out. Just PM me and I'll get back to you.
 
1 - 5 of 5 Posts
Top