Toyota Nation Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
I need some help, I have a 94 toyota pickup SR5, extended cab 4 X 4. I had some noise in the front end and got my CV Half Shafts Changed out.. Very Costly. Now I still have the same noise. While driving at high speeds there is no noise but when going 5-10 MPH there is a very loud "clicking " coming from the driver side wheel area. HELP!
 

·
Languishing in Virginia
1994 XtraCab 4x4 P/U
Joined
·
2,026 Posts
Spindle Bushings? Anyone else have a suggestion?
 

·
Registered
1989 Pickup 4WD
Joined
·
586 Posts
Try checking for play in the front suspension. Use a jack to jack the front driver tire up in the air. Grab the tire at the 12 and 6 position and try to move it. There should be no movement. If there is movement you could have a bad wheel bearing. Next, bump up against the tire with your knees/body and see if there is any play, or if you can move the tire any. It shouldn't move. If it does, start pushing and pulling on the different steering components near all the ball joints. Could be an outer-tie-rod-end, idler arm, center link, anything! When ball joints go bad, they tend to do weird things at certain speeds. I had my idler arm and an outer-tie-rod-end go bad and it only affected my steering wheel at 40 - 45mph.

Do you have manual hubs? You could take them apart. I had one of the gears slip off the spring in my manual hub, didn't make any noise, but I couldn't figure out why 4 wheel drive wasn't working :lol:. Here's an idea of how the hubs come apart and go back together: http://4x4wire.com/toyota/maintenance/front_end/hub_rebuild/

Maybe check inside the front differential? Just undo all the bolts, put a catch-pan under it, drain the fluid, and take a look at your ring and pinion. Sift through the used gear oil for metal parts, or anything that could have made a clicking noise. When you go to fill it back up, 75w-90 gear oil is what the Toyota owner's manual calls for.

Good luck!
 
1 - 3 of 3 Posts
Top