Toyota Nation Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
First, I'm new to the forum. Been Looking at it for a couple of hours and am very impressed, great forum...

I have a 95.5 2.7 4x4 5 speed Taco with 297,500 miles. Driving home the other day everything normal, stop at a red light, turns green, try to go and choke choke...dead. Tried to crank it...nothing. Got it home, suspecting fuel delivery, checked relays...ok, replaced fuel filter...cranks...idles a few seconds and dies.

I bought a fuel pressure gauge, hooked it up. When I crank the truck (engage starter) fuel pressure jumps up. When it cranks, the fuel pressure drops over the course of a few seconds till it dies.

I am getting power at the Circuit opening relay when I Crank (engage starter), but when the enginge cranks and I let off the starter, there is no fire at the relay.

What controls the fuel pump? What sensors tell it to go or no go? Any Ideas?

Many Thanks. I look forward to spending time in the forum.

jamey
 

·
Registered
Joined
·
2 Posts
Discussion Starter #2
ok..after a little more investigation, it looks like the crankshft position sensor may be what controls the fuel pump.... does that sound right?? If so...

If the sensor checks out ok, is it possible that the timing chain slipped enough to shut off the fuel pump, but not so much that the engine can still crank and idle (with supplementary fuel. When It fires up I can keep it running by shooting a little starting fluid in the intake) Does this theory even make sense, or is it just too late on Saturday night for me to be thinking??:)

Thanks for any input.
jamey
 
1 - 2 of 2 Posts
Top