Toyota Nation Forum banner
1 - 8 of 8 Posts

·
The Pwnstar
Joined
·
247 Posts
Discussion Starter · #1 ·
hey so i read that these are basically the same designs..
the haynes manuals are the same...

so im hoping somebody on here is knowledgable on the geo prizm i am working on.

i have a radiator that i need to replace on a geo prizm.
i know where the two main radiator hoses go but there is a spigot on the bottom fo the radiator near the center and i dont know where that goes.
theres no tubing for it so i cant trace it to anything.

also where does the hose go after the coolant overflow tank? looks like it just hangs out...


does anyone have a diagram of all this or even a haynes manual Scan?

Thanks
Fred
 

·
Premium Member
Joined
·
6,403 Posts
The spigot is the drain valve.

There should be another small tube facing sideways under the radiator cap that goes to the overflow tank.

Try the Autozone website for info.
 

·
The Pwnstar
Joined
·
247 Posts
Discussion Starter · #3 ·
no no i think were mis understanding each other...
when facing the car.. so that driver is on right

there is a spigot with a plastic wing nut all the way to the left...
1) a golden spigot in the center for a rubber hose to attach to
2) another golden spigot on the drivers side for rubber hose to connect to

on spigot 1, i dont have any tubing connected and i can not find where it should be connected or just open...

spigot 2 is connected to a pipe that looks something liek an abs line... that is under the overflow tank

the spigot under the radiator cap is goign to the overflow tank. but out of the overflow tank cap, is another hose that just seems to be going nowhere.. and sits between the tank and the battery but just hanging...


i dont know where spigot 1 needs to be connected to
ill look on autozones site..

thanks
 

·
Registered
Joined
·
398 Posts
is yours an auto or 5spd?
 

·
You asked for it...
Joined
·
407 Posts
when facing the car.. so that driver is on right

there is a spigot with a plastic wing nut all the way to the left...
1) a golden spigot in the center for a rubber hose to attach to
is this the one on the bottom? if so, it's the drain, so nothing needs to connect to it, just tighten it up.

... out of the overflow tank cap, is another hose that just seems to be going nowhere.. and sits between the tank and the battery but just hanging...
This is normal; it's an overflow for the overflow tank.
 

·
The Pwnstar
Joined
·
247 Posts
Discussion Starter · #6 ·
is this the one on the bottom? if so, it's the drain, so nothing needs to connect to it, just tighten it up.
i meant to list that as two things.

there is
1) a plastic wing nut with a small tube coming out under it.
2) a golden spigot in the center


see:
http://www.car-stuff.com/store/images/prodimage/images/aftermarket/432359.jpg


in this picture from left to right.
there is:
-one foot support for the rubber rings
-first golden spigot
-bottom radiator hose connection
-second golden spigot
-one more foot support for the rubber ring
-drain nut



i know where the first golden spout goes. just not the second one.

srry for the confusion. and thanks for ht ehelp


btw
this is an automatic.
 

·
The Pwnstar
Joined
·
247 Posts
Discussion Starter · #7 ·
not really sure.. but taking a guess..
doesnt some other fluid also run through the radiator?
not for the ac but maybe the atf?

or was it oil?
i really dont know. .but it sounds like ive heard it before..

if this is true.. im gunan lean towards atf.. since there was red on the hose of the first spigot that i could see where it originalyl went..

but the coolant was also red.. and it may be because my friend spilt coolant on that hose or something..
 

·
The Pwnstar
Joined
·
247 Posts
Discussion Starter · #8 ·
aha aright so i jus tlooked in my haynes manual that i foudn for my subaru... and i see here that it is for atf cooling....

so basically all i need to know is where does it go back into the transmission pan. and how long of a hose d i need
 
1 - 8 of 8 Posts
Top