Toyota Nation Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
23 Posts
Discussion Starter #1
i was wondering if anyone has had the tsb for engine knock on 10th gen corolla performed, mine is supposed to go in to be fixed next week, if anyones has been performed..... did they really fix it, do u hear the noise anymore????
 

·
Registered
Joined
·
27 Posts
I had it performed and it did fix mine. Doesn't rattle at all now.

Side note - I think there were two noises people are complaining about.

One is a legit grinding rattling noise, it is loud. It sounds like metal on metal. That is what the TSB is for.

There is a little fluttering hum noise I hear sometimes on startup, it is not loud or metalic... but I do notice it sometimes. My car still does that - it did it before the TSB. I think some people are taking their car in for that noise and the TSB is not addressing it, so they are still unhappy. I just remind myself I bought a 4 cylinder Corolla... it is not going to be the image of absolute refinement - just a dependable car.

3 threads in the first three pages - is this what you are looking for?

http://www.toyotanation.com/forum/showthread.php?t=338984

http://www.toyotanation.com/forum/showthread.php?t=357804

http://www.toyotanation.com/forum/showthread.php?t=357313

and link to pdf of tsb:

http://www.empirepao.com/tsb/T-SB-0087-09.pdf
 

·
Megan Exhaust
Joined
·
507 Posts
I had one for a rattling noise a while back but they said it was the belt and they replaced it with a new one tightened it to specs and no more noise.
 

·
Registered
Joined
·
23 Posts
Discussion Starter #5
mine is the same noise linked at the top, it can be rather loud, almost sounds like a rod knocking somtimes. wut tipe of noise did it make with a loose belt, mine is only on startup
 

·
Megan Exhaust
Joined
·
507 Posts
Mine was only on start up to. When it was cold. And then it would stop. It sounded like an engine knock. Like if you could here the lifters hitting something but it was the belt and it was fixed after that no more noise.
 

·
Registered
Joined
·
23 Posts
Discussion Starter #7 (Edited)
mine does it on warm starts. when i crank it in the morning after it sits all nite it dont do it, but after i drive it and cut it off for about 30min to an hour it makes all the noise...does urs do it when its actually cold or just after it sits for a few minutes?
 
1 - 8 of 8 Posts
Top