Toyota Nation Forum banner

1 - 4 of 4 Posts

·
Registered
1993 toyota pick-up
Joined
·
8 Posts
Discussion Starter #1
im new here and i have a 93 yota pickup with the 22R-E 4 cyl and a 5 speed manual 2 wheel drive and i just replaced the head gasket and all the other gaskets and i got it all back together and now it will only start after about 3 min of cranking and idle very low with the throttle all the way to the floor. i just got this truck because of the blown head gasket but i got it from the original owner and i did a brake job on it about 2 weeks ago so i know it ran perfect before the waterpump took a crap and blew the head gasket. if anybody has any ideas please chime in im open to anything. also im getting fuel to the injectors and the cat and exhaust is clear and not plugged, all vacuum lines and electrical has been triple checked and is correct. :headbang: thanks in advance
 

·
Registered
Joined
·
78 Posts
sounds like you have the timing wrong. did you move the distributer at all? because if not when the timing chain was put on it is not lined up exactly. could be off by only a few teeth.
 

·
Registered
1993 toyota pick-up
Joined
·
8 Posts
Discussion Starter #3
is there a reset for the electric fuel pump on these trucks, because now it will fire up perfectly but as soon as it idles down it dies out like not getting fuel.
 

·
Registered
1993 toyota pick-up
Joined
·
8 Posts
Discussion Starter #4
figured it out we didnt have the intake tube connected and the air meter wasent seeing the flow of air so it was shutting us down, we reconnected it and it fired right up and purred like a kitten.
 
1 - 4 of 4 Posts
Top