Toyota Nation Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
245 Posts
Discussion Starter #1
i have a 99 v6 camry with 104k miles. its been taken care of properly and has had the usual maintenance.

about 4 months ago my car would occasionally shudder when switching into drive from park, neutral, or reverse. it would kind of feel like doing a neutral drop at very low rpms. i changed the tranny fluid which didnt do anything.

3 months ago by check engine light goes on. the car is still running fine. it went out after driving it about 5 or 6 times.

now fast forward to recent times. it will still shudder about the same as it has been doing. now sometimes when i am stopped, either in park or with my foot on the brake, the rpms will jump up to 1,000 then immediately drop down to about 800 where it usually idles. it will do this maybe every 5-10 seconds until i start to drive. i have never noticed this before so i dont know if it is normal or not. lately when driving my tranny seems to take long to shift. when i accelerate from a stoplight it will usually shift at about 2800 rpms when i get to 40-45. now instead it wont shift until i get past 3k.

this morning my check engine light came on again.

my driving habits have stayed the same so i dont know what is going on.
 

·
Not so Noob now!
Joined
·
564 Posts
You might have multiple problems. The first problem sounds like it could be caused by a bad motor/tranny mount. The check engine light could be caused by any number of things. A bad throttle position sensor might be the culprit, and it might explain why your car is acting up otherwise. Other than that you really should check into finding out what code is causing your light to come on. There are other threads here that cover how to get the codes.
 

·
96 3MZ M/T
Camry
Joined
·
2,879 Posts
take the car to autozone they read the codes for free. also look at your front engine mount and the dog bone mount on the side they need to be replaced. it the car feels like it's pulling a little from park to drive front mount, park to reverse then back mount as well. come back with what autozone says what the code is and we can help you out. also check for loose vaccume lines.
 

·
getn groceries in style
Joined
·
1,095 Posts
prophesized said:
well the engine light went out earlier today.

how can i tell if the motor mount is bad?
start the car and put it in park... pop your hood... rev the engine with the throttle and see if your engine moves front/back. if it does eccessively, bad motor mount.

jon
 

·
96 3MZ M/T
Camry
Joined
·
2,879 Posts
dosent matter if the light turn back off unless you disconected the battery or pulled the fuse. the code is still stored in memory and can still be read.
 
1 - 6 of 6 Posts
Top