Toyota Nation Forum banner

1 - 16 of 16 Posts

·
Registered
Joined
·
58 Posts
Discussion Starter #1
Ok ...heres my delima :( I was "driving" and i was shifting from 1st to 2nd gear when my damn universal shift knob came off and i over reved and now my car is makin sputtering noises and when i drive and shift gear it takes long shift into the other gear can any one partialy help me :(
 

·
Got Hardass?
Joined
·
2,959 Posts
1) What year Supra do you have?
2) How high did it end uo rev-ing?
3) What type of sputtering? Like a miss? does it sound like it's not properly firing on all cylinders?
4) "Takes long shift" What do you mean?
 

·
Got Hardass?
Joined
·
2,959 Posts
If you can 100% figure out wtf he's talking about in his first post, you win the bonus points, I sure can't.
 

·
Registered
Joined
·
58 Posts
Discussion Starter #5
....

Here...

1.1988 toyota supra w/ 92 Turbo engine in it.
2.It reved up to 4800RPMs in 1st gear
3.And I think it possibly sounds like its miss so i am guessing i got oil on too the spark plugs.
 

·
5M-GE
Joined
·
2,901 Posts
i hope it's not rod knock :eek:
 

·
Registered
Joined
·
58 Posts
Discussion Starter #7
huh?

You mean the rocker arms knockin?...Another thing too is when i accelerate at 4000RPMs it turns off but when i switch the gears it stays on??? !!!!
 

·
5M-GE
Joined
·
2,901 Posts
your problem may be transmission related.

for the sake of your car, don't drive it any further. take it to a qualified mechanic. please.
 

·
Premium Member
Joined
·
5,005 Posts
he only revved to 4800rpm in first....i think redline is a little ways further.....so i don't think that could have caused much damage to the tranny.....
 

·
5M-GE
Joined
·
2,901 Posts
MRQturbo said:
he only revved to 4800rpm in first....i think redline is a little ways further.....so i don't think that could have caused much damage to the tranny.....
but it did something... :confused:
 

·
Registered
Joined
·
58 Posts
Discussion Starter #13 (Edited)
Its fine

apparently oil burns up and thats whats happen thats what my mechanic told me i was freakin out all i need is oil
 

·
5M-GE
Joined
·
2,901 Posts
Re: Its fine

o_0 said:
apparently oil burns up and thats whats happen thats what my mechanic told me i was freakin out all i need is oil
the oil is going somewhere. something is wrong with your car. you do need oil.

but that is not all you need. I forsee rod knock, as well.
 
1 - 16 of 16 Posts
Top