Toyota Nation Forum banner
1 - 16 of 16 Posts

·
Registered
Joined
·
58 Posts
Discussion Starter · #1 ·
Ok ...heres my delima :( I was "driving" and i was shifting from 1st to 2nd gear when my damn universal shift knob came off and i over reved and now my car is makin sputtering noises and when i drive and shift gear it takes long shift into the other gear can any one partialy help me :(
 

·
Got Hardass?
Joined
·
2,959 Posts
1) What year Supra do you have?
2) How high did it end uo rev-ing?
3) What type of sputtering? Like a miss? does it sound like it's not properly firing on all cylinders?
4) "Takes long shift" What do you mean?
 

·
Registered
Joined
·
58 Posts
Discussion Starter · #5 ·
....

Here...

1.1988 toyota supra w/ 92 Turbo engine in it.
2.It reved up to 4800RPMs in 1st gear
3.And I think it possibly sounds like its miss so i am guessing i got oil on too the spark plugs.
 

·
5M-GE
Joined
·
2,901 Posts
your problem may be transmission related.

for the sake of your car, don't drive it any further. take it to a qualified mechanic. please.
 

·
5M-GE
Joined
·
2,901 Posts
MRQturbo said:
he only revved to 4800rpm in first....i think redline is a little ways further.....so i don't think that could have caused much damage to the tranny.....
but it did something... :confused:
 

·
5M-GE
Joined
·
2,901 Posts
Re: Its fine

o_0 said:
apparently oil burns up and thats whats happen thats what my mechanic told me i was freakin out all i need is oil
the oil is going somewhere. something is wrong with your car. you do need oil.

but that is not all you need. I forsee rod knock, as well.
 
1 - 16 of 16 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top