Toyota Nation Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
13 Posts
Discussion Starter · #1 ·
I have a 01 corolla with 160,000 miles. Everytime i turn on the ignition, I hear a high pitch noise. Replaced the spark plugs and ignition coils. Could it be a vacuum leak? Where would I check for vacuum leaks?
 

·
Registered
Joined
·
510 Posts
Can you feel the engine missing?
Take a can of WD40 and with the engine at idle, spray around where you think the leak might be. When you do hit the leak, the WD40 will make the engine speed up slightly, then you have found your leak.
I like to use a small propane torch can with a rubber hose attached, WD40 is cheaper, easier to find and less flammable.
 

·
Registered
Joined
·
10 Posts
Do you mean when cranking the engine?
You may have loose or worn auxiliary belt/s.Could be bad water pump or alternator bearing.Removing the belts and cranking could help eliminate some items
 

·
Registered
Joined
·
13 Posts
Discussion Starter · #6 ·
The drive belt was replaced a long time ago but not the water pump. So you think i should replace the water pump? The cooling system is fine with no overheating problems in the engine.
 

·
Registered
Joined
·
510 Posts
Could be the tensioner pulley bearing also, Common to go out . I have had to replace one at 100,000 and repack the the next one at 205,000. Makes alot of noise when going bad

The water pump is another common problem , usually way before 160000, but mine has lated 207000 without problems.
 
1 - 7 of 7 Posts
Top