Toyota Nation Forum banner

1 - 10 of 10 Posts

·
1996 Camry V6
Joined
·
25 Posts
Discussion Starter · #1 ·
I own a 96 v6LE 1mzfe only 84000 and from time to time when I brake to come to a stop the rpms keep going up like the car wants to keep going, like something is stuck. I usually just kick the shit outta the gas pedal and let is sit for a little bit and its fine. I changed the air filter and took off the intake hose and cleaned the hell out of the throttle body and it is still doing to. Just wondering if anyone has any ideas on what the problem may be.
 

·
Registered
Joined
·
131 Posts
sounds like a vaccum problem...you might have a leak in a vaccum hose or one might have disconnected.... when you turn off your car check for a hissing sound....if so then you do have a vaccum hose thats leaking or most likely disconnected.
 

·
TN Pussy Man
Camry
Joined
·
13,302 Posts
^ what he said...

but more importantly, check for leaks between your maf and your throttlebody- ANY leak there will cause havok and surginging as well as stalling problems and a/f problems


one way to find a vacuum leak is by using throttlebody cleaner....just start spraying it around areas where there could be a vacuum leak- if your engine starts surging (since throttlebody cleaner is combustible), then you've found your vacuum leak
 

·
Registered
Joined
·
184 Posts
I think a vacuum leak is more likely to cause a rough idle. Problem could be an idle control valve sticking..?
 

·
1996 Camry V6
Joined
·
25 Posts
Discussion Starter · #5 ·
I forgot to mention that this doesnt happen all the time. Usually only happens once every couple weeks, I dont know if that makes a difference or not.
 

·
TN Pussy Man
Camry
Joined
·
13,302 Posts
alotawatts said:
I think a vacuum leak is more likely to cause a rough idle. Problem could be an idle control valve sticking..?

actually, he makes a good point here....pre-throttlebody vacuum leaks usually affect the idle

I would look for vacuum leaks post throttlebody as suggested by coquibone14
 

·
1999 Camry V6 Auto
Joined
·
57 Posts
Sorry to cut into someone else's topic, But...

I think I have a similar problem. I've noticed that sometimes, when the engines been going hard for a bit, it would rumble and the RPM would fluctuate slightly when I'm stopped at a light. So pretty much a rough idle. It only happens when the engines hot though. Do I have some sort of vacuum leak aswell? If so, what do I need to do/look for?
 

·
TN Pussy Man
Camry
Joined
·
13,302 Posts
^ that would be your IAC - probably needs a cleaning, and it can't keep up with the vacuum/air demands needed to keep your idle steady after it gets hot

do a search on how to clean your IAC

if that doesn't work, you can also turn up the base idle enough so that the IAC can catch up- but on a stock engine, you shouldn't have to do that
 
1 - 10 of 10 Posts
Top