Toyota Nation Forum banner

181 - 200 of 293 Posts

·
Registered
Joined
·
84 Posts
yup thanks, i just saw it it's about 10 bucks.

still thinking if I should get it or not .... dunno if it will make the car seem older than what it looks like ....

 

·
Registered
Joined
·
360 Posts
This is awesome to see! I just picked up mine several weeks ago with 128k.....we'll see how far mine goes. It has a repetative vibration in it though, it has a pattern to it, vibrates for one second, waits 3 and vibrates for another one.....Prob nothing though
 

·
Registered
Joined
·
84 Posts
does it vibrate at idle only, or when you drive .when you brake.....?

if it idle could be as simple as plugs, while driving could be tire, suspension parts, braking could be rotors and such ......

all in all probably just normal wear and tear ....make a post with your problem and describe symptoms .....

on a side note, the funiest part about it, at 250k i still leave many cars eating dust.....with no mods.....

a guy in a mustang (older probably 95-05) asked as he caught up at a stop light ......"what' you got under there" .... i said 1-FMZ ......i got a "yeah that's cool" ...... i wonder if he knew i just wanted to make my engine/intake sound way better than what it is .......the only mod i have is my aftermarket 1004 JVC head unit and 2 extra speakers over stock and a 3$ junkyard extra power outlet ......
 

·
Registered
Joined
·
360 Posts
lol!

Ehhh i only feel it at like 55mph or so, maybe more. It's weird because it's not a constant vibration, it's vibration with a temp. Like I said vibrate one second, wait 5 vibrate another second and repeat. It's weird......Nothing I've seen on a Fbody. Nothing horrible, but I notice it.
 

·
Registered
Joined
·
84 Posts
are you sure tires ok, i had the same thing on my concorde and then when i got new tires it disappeared with no alignment or anything but just new tires...

also if you have the xls alloy wheels they are very weak and bend easily, mine gives a vibration , something like what you said, and sometimes you don't feel it, especially once you pass 65-70 mph. 3 Different places on my last 2 sets of tires said the same wheel is bent a bit .... and if i'm not mistaken is the same one i hit on a curve really bad to where it even caught grass between tire and wheel.... so ....i just ignore it since i do kinda like them ... I will grab one from the junkyard ....someday
 

·
Registered
Joined
·
360 Posts
ehhh but it's not a constant vibration. If it was something in the wheels it would constantly vibrate every time it makes a rotation. It vibrates a real little bit, goes away, comes back a second, goes away, comes back a second and goes away, in a cycle. In the time it takes for the cycle any one of the wheels would have spun 5-10 times.
 

·
Registered
2007 Tundra Double
Joined
·
90 Posts
270000

Finaly rolled 270,000 on the 96 Avalon yesterday. It was kind of exciting wathching all the numbers but the 2 rolling over. Yea, I know, I need a life right? Took a picture of the odometer but I don't know how to upload it. Oh well.
Also develoved some sort of road induced clunk coming from the front of the car somewhere. Happens when I go over bumps etc. Oh boy, I get to play mechanic today.

Looks like the drivers side cv joint. Rats!
 

·
Registered
Joined
·
2 Posts
Go avalon!

I bought mine 2 months ago with 257,000 on it. now at 258 and I've spent $400 in it on tie rods. Everything still works great, no rust or dents. not bad for a 96 xls with a kick butt audio system!
 

·
Super Moderator
Joined
·
12,811 Posts

·
Super Moderator
Joined
·
12,811 Posts
No prob. I've done that too! :lol:
 

·
Registered
Joined
·
3 Posts
Will my next toyota last this long?

1996 with 228,000

Suspension dead
Leaks about two quarts of oil a month
Doors fill with water when it rains
Seat motor broken (if you are less than 6' tall you can't reach the pedals)
Cruise control broken
Yet has NEVER broken down on the side of the road.

Being it was once in 3 feet of water for a few days, I'm incredibly happy :D

Looking at buying a 2009 Matrix XRS - Could it do the same or in the golden age of toyota over?
:worship:
 

·
Registered
1998 Avalon
Joined
·
4 Posts
I've been driving my '98 since it was new, commuting 100 miles daily and I just turned 427,000 miles.

Still getting 30 mpg, no major work, no leaks, doesn't burn oil, changed struts twice, front control arms last month, front pads once, oil change 3-4 Kmiles. I think driving the freeway 90% of the time makes a huge diff.

It runs almost as good as new and the tranny has the original fluid/filter.

Gonna buy a new one someday, if this one ever quits.
 

·
Super Moderator
Joined
·
12,811 Posts

·
Registered
1998 Avalon
Joined
·
4 Posts
I started to change them at 250 K but when I pulled the calipers off and saw they still had about 1/4" left I took the pads back to the dealer for a refund. The said I wasn't the first to bring back front pads. I still have the orignal rear pads and the brakes are still very good! Freeway driving out here on highway 58 is the reason. Hardly ever have to touch the brakes.
 

·
Mechanical Engineer
Joined
·
24 Posts
It has been a little while since I updated here.... mine sat about 8 months with what I thought was a broke timing belt. I drug the old girl out and put one on it Saturday night 2 weeks ago. I quickly realized upon removing the 2 timing belt covers that this was not causing my car to not run..... replaced it all anyway.... still no start. Next night I checked the fuel pump (which I had replaced by a shadetree mechanic I worked with less than 1000 miles ago). I could hear it run everytime I turned the key on. I then pulled a plug and grounded it and spun the motor over... had good fire..... then decided to check for fuel at the fuel rail.... cracked one of the lines... cycled the pump... no fuel at the rail. Long story short....shadetree didn't put the hose clamp on the line where it ties to the fuel pump.... and the FP worked it's way loose and was laying in the bottom of the tank... not hooked up to pipe at all! 10 min later she was purring again. I have been driving it to work since Monday..... now has 331k on the clock.

Next repair items..... valve cover gaskets and spark plugs and a new radio. My CD player skips like there is no tomorrow.

I plan on driving it til north of 400k.

On a related note.... went to the pull-a-part Saturday for a few things and the '95 I got parts off of had 410k on the odometer. These cars will run forever.
 
181 - 200 of 293 Posts
Top