Toyota Nation Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Hi all

I own a 1996 corolla - 1.3 XLi

The instrument panel is the type without a tachometer, i.e. 3 dials - speedometer, petrol gauge and temperature.
Here's the thing:

On the speedometer the lower right numbers (200 km/h and 220 km/h) are less illuminated than the rest when backlighting is on. I assumed a bulb had gone so replaced the four coloured bulbs on the back of panel. No joy. The lighting is brighter, but still uneven.
And here's the odd thing:
When i press the trip-counter pin to reset the counter the uneven lighting suddenly becomes as bright for those two speeds as the rest of the dial. Until I release it - then they go back to dim again.

Anyone have any ideas?

Cheers
 

·
Bullitprooph
1986 MR-2 N/A, 1991 Celica GT-S, 2005 Matrix XR, 2009 Matrix XRS, 2009 Matrix Base
Joined
·
1,504 Posts
I've had this happen before on my (older) Yotas. If you can take the guage pod back out, there may be a piece of plastic film inside that has pulled loose and is obscuring part of the bulb's light. Try removing the clear plastic face and poking around (carefully) with tweezers...
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #3 ·
Thanks!

"Try removing the clear plastic face and poking around (carefully) with tweezers..."

Do you mean remove the plastic screen and insert the tweezers aroung the side of the speedometer face (without having to unscrew the panel itself), or do I have to remove the whole instrument panel and unhook the speedometerfirst ?

Cheers
 
1 - 3 of 3 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top