Toyota Nation Forum banner
1 - 8 of 8 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
Hi toyota friends, I recently bought a 1999 Avalon from a dealer. It came with a remote but it is not working. I changed the battery and tried all the door open/close options but still no luck.

I also noticed a Toyota Security in the left of my steering but does not know what it is or whether it is related to my keyless remote or not. But I noticed that it is dead, there is no led or no sound comes from it.

I really appreciate if someone can help me to make this remote working.

Thanks,
punnu17
 

·
Registered
Joined
·
145 Posts
keyless

First what i would do is goto any autozone(i think they are the only ones that do this) they have a rack with remote batterys on then and have a box there that will allow u aim the remote at it and it will blick if u press a button on the remote indicating that ur remote is transmiting a signal.


Next i would try to reprogram your remote to the car. here is the info for that.

http://www.programyourremote.com/classified/DisplayAd.asp?id=1207

if that dont help maybe call the dealer where u bought it *toyota dealer im assumeing) and see if they can fix it for you.
 

·
Registered
Joined
·
56 Posts
My keyless stopped working for a while. I never tried to fix it. There is a fuse & relay box under the hood, the smaller one which is closer to the driver, with 3 relays, I unplugged the second relay and plugged it back, then the keyless works again now. Mine is a 97 Avalon.
 

·
Registered
Joined
·
211 Posts
i have seen the wire connector that attaches to the driver door lock get messed up. this usually causes the doors to lock and unlock by themselves sometimes. its a 60 dollar part from toyota.
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #5 ·
Thanks a lot for your answers. Mine is not automatically locking and unlocking so there seems to be something else.

I checked all the fuses under the hood and under the stearing but all are fine.

I will goto autozone and to verify the remote. But I already tried to reprogram the remote so I hope that the remote is bad :D.

Thanks,
Puneet
 

·
Registered
Joined
·
15 Posts
Mine wasn't working when I first got the car, so I replaced the battery and still nothing. I then opened it up and bent the metal connectors that touch the battery a little bit to make sure it was in contact (careful they are fragile). I'm not sure if this actually did anything, but now i can unlock/lock if i'm standing 45 degrees from the front of the car and back about 10 feet, and i usually have to press pretty hard on the button.
 

·
Registered
Joined
·
145 Posts
remote

Mine wasn't working when I first got the car, so I replaced the battery and still nothing. I then opened it up and bent the metal connectors that touch the battery a little bit to make sure it was in contact (careful they are fragile). I'm not sure if this actually did anything, but now i can unlock/lock if i'm standing 45 degrees from the front of the car and back about 10 feet, and i usually have to press pretty hard on the button.
yea mines the same its real annoy since the 95 96 avalons dont flash the marker lights when you lock or unlock the car. im working on installing a fix for that lol
 

·
Registered
Joined
·
37 Posts
I had the same issue with mine. I checked the battery and it was good. Then I pulled the rubber off of the front of the circuit panel on the front of the keyless, and there I found sticky residue from what was probably a spilled soda. Rubbing alcohol on a cotton swab cleaned it up- good as new. Keyless is a luxury that I never had before.
 
1 - 8 of 8 Posts
Top