Toyota Nation Forum banner

1 - 7 of 7 Posts

·
surfing TN via Iphone
Joined
·
237 Posts
Discussion Starter · #1 ·
For the last few weeks I have noticed a loud popping noise when turning sharp or coming to a quick stop. I have toytec coilovers in the front but it seems like something to do with the steering. Any ideas as to what could be causing the noise?
 

·
'Coma Nut
Joined
·
1,210 Posts
Have you checked the front end (suspension, steering) of the truck?
 

·
30YRTOYOTAPARTSEXPERINCE
04 Camry; 09 Sienna
Joined
·
1,237 Posts
If it is a 4X4, i'd check the axles. Sounds just like an axle symptom on a front wheel drive vehicle.
 

·
surfing TN via Iphone
Joined
·
237 Posts
Discussion Starter · #4 ·
Have you checked the front end (suspension, steering) of the truck?
Yes and nothing looks out of the ordinary. Even happens while backing up sometimes. Almost sounds like something is shifting and hitting another part.
 

·
'08 tacoma pre-runner
tacoma
Joined
·
520 Posts
What size tire are you running? It might be rubbing on your cab mount if your going with 33's

EDIT: did not read the coming to a stop and i dont think popping would be a result of tires rubbing but possibly. If/when you/they installed the coilovers did the install go above what needed to be unbolted? Maybe they did not tighten down the LCA enough or the tie rod might be shit. Dont the tie rods make a popping sound once they are bad?
 

·
jorgem2
2006
Joined
·
74 Posts
Check the wheel bearings, see if you can lift up the truck by the lower control arm so the suspension is not at full droop. One side at a time and wiggle the wheel in and out to check for bearing looseness. Also with the same wheel in the air, see if you can use a pry bar and pry the wheel up down, in out while you check the ball joints, Or have someone do this while you look for play in the ball joints.
Just dont stick anything under the wheel in case it shifts and falls off the jack.

Also look for oil leaking from a broken shock/strut. I had a oem bistein break internaly, so the piston was loose inside and made a popping sound sometimes.
 

·
'Coma Nut
Joined
·
1,210 Posts
Yes and nothing looks out of the ordinary. Even happens while backing up sometimes. Almost sounds like something is shifting and hitting another part.
Did you just look at it or did you check all components for play?

If you know for certain that some components are not the culprit, list that in your post so we can eliminate components one at a time. No point in members wasting their time and telling you to check a dozen items if you already know they are fine.
 
1 - 7 of 7 Posts
Top