Toyota Nation Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
I have a 2010 Venza V6 AWD with the Canadian Premium package which I bought just over 2 months ago.

I have noticed the following intermittent behavior. After I start the Venza, and after the normal warning lights system check have displayed and turn off, the Master Warning Light and the Slip Indicator light will immediately flash on for a second along with the warning buzzer sound. Both lights will immediately turn off and does not come back on during my drive. For the majority of the time when I start my Venza, these two warning lights do not flash on after the car has started. I only observe this behavior about 2 – 3 times per week (about 15% of the time).

Is this normal behavior, or do I need to get the dealership to check on something.

Thanks for any insights.
 

·
Registered
Joined
·
451 Posts
Sounds like it's the "hill start assist" (or whatever it's called).
Try not pressing as hard on the brake when you start the car and it should go away.
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
Initially, I thought it might be the Hill Assist option. But, with that option, only the Slip Indicator light turns on, and then turns off when I step on the gas.

In my situation, the Master Warning light also turns on. Less than a second later, with my foot still on the brake, both the Master Warning light and the Slip Indicator light will turn off by itself.
 
1 - 3 of 3 Posts
Top