Toyota Nation Forum banner
1 - 20 of 25 Posts

· Registered
Joined
·
12 Posts
Discussion Starter · #1 ·
Been changing injectors still run rought at idle all spaks plug and elecrical unit on it is ok cause when you unplug connector on injector no 4 ( engine stall almost ) been looking at my throttlebody gasket and this unit is out of 2 peace with a rubber gasket the i have a 4 hole base about 1 inch high another 4 hole steel gasket and the throttlebody as anybody have a detailled picture of this once it apart and do you think my problem could be the steel gasket cause it is rought.

Thanks to all

Guy
 

· Registered
Joined
·
12 Posts
Discussion Starter · #11 ·
Before having those 2 codes I was getting P0304 rought idling at a garage (not toyota) mechanic told me that it was a dirty valve that stayed open he told me that with pressure he could hear the leak Is that possible cause spoke to another getlemen that work at Toyota for 16 years not as a mech but service manager and never he saw a engine with faulty valve did try to clean valve with spray in the trhottle body no result
 

· Super Moderator
1995 T100 2WD & 1993 MR2
Joined
·
18,708 Posts
The Throttle body valve aka the throttle plate can get dirty and stick open a small amount and sometimes you can hear the air rush by. If the leak is big enough it will cause the engine run rough or idle erratically. Cleaning a TB or MAF Sensor with a spray is common, most techs will have a can of cleaner on their tool boxes and do it out of habit and don't bother to bill for it.
 

· Administrator
マズダスピード3
Joined
·
18,891 Posts
Now 304 disapeared and now after cleaning mt trhottle body got P2135 and P0123 hmmm
Double check your connector for the throttle body is connected. Pull intake tube off and have helper press down on the gas pedal. Monitor throttle plate when opens and closes.

Do you have a scanner that can measure throttle input?
 

· Registered
Joined
·
12 Posts
Discussion Starter · #17 ·
Got rid of both codes and back to P304 clean everything from trottle body maf sensor brand new injector and still got that almost stalling issue at idle could that be a valve not shutting or adjust properly
 

· Administrator
マズダスピード3
Joined
·
18,891 Posts
A misfire is pretty vague in locating the culprit. It could be a spark plug, coil pack or something internal. Like a spark plug seal allowing oil to get onto the spark plug during operation.

Since the throttle body is electronic, you need to try to isolate the function. It’s connected through the gas pedal and with help of a scan tool with Pid controls, it can be actuated through the tool. Otherwise, you’ll need to measure continuity and voltage between the throttle body and the pedal.

The throttle plate position can be messed with if you didn’t actuate the plate through the pedal. You may need to locate a used throttle body in the junkyard if you didn’t actuate it with the pedal.
 

· Registered
Joined
·
7 Posts
Have you done a compression check? 2st step should be to swap plug #4 to cylinder #2, and swap coil #4 to cylinder #2 and clear code. See what comes back. If it follows one of the parts, it is a failed part. If it stays with 4, then you either have an injector issue or bad compression.
 
1 - 20 of 25 Posts
Top