Toyota Nation Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
19 Posts
Discussion Starter #1
Well now that I have the speedo problem figure...here is another one...My brake lights dont work at all...and sometimes they work when i turn on the lights from the interior...and the reverse and license plate lights aren't working either...I check for blown fuses...I had one blown fuse and now my clock works again but still no lights...

Now onto problem 2...The engine's idle is very high...well not very high but it stays consistem and 1000rpm...drops when the thermostat fan turns on and then when the fan shuts off it jumps back to 1000rpm...what could cause this?
 

·
Registered
Joined
·
19 Posts
There should be an idle speed screw that you can adjust although that may not be the best way to solve your problem since something must've caused the engine to idle that high in the first place. Standard idle speed is what...700 rpm? Around there?
 

·
Registered
Joined
·
19 Posts
Discussion Starter #3
where is the screw?
 

·
Registered
Joined
·
355 Posts
If none of the back lights, including the turn signals, function, then check the wires around where you close the trunk, they sometimes get damaged.

As for as the idle, is it carb'ed or EFI? How is your gas milage.
 

·
The Return of the Red Coupe
2010 RAV4 V6
Joined
·
19,666 Posts
the RPM dropping when the fan turns on is normal, the fan draws energy from the battery/alternator so the motor drops in speed.
 

·
Registered
Joined
·
19 Posts
Discussion Starter #7
GrandmasterYang said:
Should be a big flathead screw on the throttle body if I am not mistaken. Open to correction...
Yeah it was actually a phillips on the throtle body inside this cylinder type thing...



89molavi said:
If none of the back lights, including the turn signals, function, then check the wires around where you close the trunk, they sometimes get damaged.
Sometimes they work...sometimes they dont...they have been working lately but only the tail light and turn signals...I still have no plate lights, reverse lights or even brake lights...
 

·
Registered
Joined
·
19 Posts
Discussion Starter #8
bump...
 

·
The Return of the Red Coupe
2010 RAV4 V6
Joined
·
19,666 Posts
GrandmasterYang said:
Should be a big flathead screw on the throttle body if I am not mistaken. Open to correction...
on a GTS its not a flathead, its a phelps screw, and its located behind the throttle body area where the intake pipe connects to the throttle. There's a round black rubber cover on it, easy to take off, and there you'll see the screw.
 
1 - 9 of 9 Posts
Top