Toyota Nation Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
I have taken my vehicle to a Toyota dealer and a mechanic and no one seems to be able to tell me what the problem is they can’t find it. My car starts fine in the mornings cold starts or even if it’s a hot day. But always starts in the morning when our problems. The problem starts when I drive the car and I Park it. in between 2 to 3 hours I try to start it I have to turn the key twice because the first time it does not start. The second time it does. The battery is good and it does crank fine except when I use the car after the 2 to 3 hours. Like I said the car starts find any other time in the morning or even after five or six hours. They did do the cleaning on the I forgot what you call the part they cleaned it twice with a spray. If somebody mentions the part name then I can’t remember what it’s called. So does anybody have an idea what could be causing. My Toyota 2014 Corolla LE to not start the first time after those 2 to 3 hours. I have 128,000 miles. I have change the spark plugs just in case but if the spark plugs were the issue I would always have the problems when I start the car and it doesn’t happen all the time. Thank you all in advance
 

·
Administrator
2006 Corolla XRS
Joined
·
11,000 Posts
What's the condition of your battery terminals? Any sign of corrosion? Try cleaning it with baking soda and water.

The starter needs to get tested. Sounds to me that the bendix gear in the starter is sticking and not engaging or disengaging the flywheel.
 

·
Registered
Joined
·
284 Posts
Did they clean the fuel injectors? You’re saying it cranks but only starts on the second try after engine off for a few hours.

It sounds to me like a fuel pressure problem that could be due to a stuck open Evap valve, failed fuel regulator, and/or dirty fuel filter in the gas tank. There’s supposed fuel pressure in the system to restart the car after a few hours sitting still. It will not trigger a code. Have that inspected.

Fuel pressure could also leak with a faulty gas cap. But this should trigger a code or CEL.


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
6 Posts
Discussion Starter #4
What's the condition of your battery terminals? Any sign of corrosion? Try cleaning it with baking soda and water.

The starter needs to get tested. Sounds to me that the bendix gear in the starter is sticking and not engaging or disengaging the flywheel.
Battery terminals look good but don’t explain that’s the issue only happens 2-3 hrs after I turned the car off then I need to go out and the issue happens. Also starter issue would happen other times. But this only happens after I used it then need to use the car again after the 2-3 hrs.
 

·
Registered
Joined
·
6 Posts
Discussion Starter #6
Did they clean the fuel injectors? You’re saying it cranks but only starts on the second try after engine off for a few hours.

It sounds to me like a fuel pressure problem that could be due to a stuck open Evap valve, failed fuel regulator, and/or dirty fuel filter in the gas tank. There’s supposed fuel pressure in the system to restart the car after a few hours sitting still. It will not trigger a code. Have that inspected.

Fuel pressure could also leak with a faulty gas cap. But this should trigger a code or CEL.


Sent from my iPhone using Tapatalk
I don’t think they did. I think I can do that with seafoam. Unless you u think I should just let the shop do it. I will check on the Evap valve. But wouldn’t it also happen when I turn on the car in the mornings ? Fuel pressure I will ask about that.
 

·
Registered
Joined
·
284 Posts
I don’t think they did. I think I can do that with seafoam. Unless you u think I should just let the shop do it. I will check on the Evap valve. But wouldn’t it also happen when I turn on the car in the mornings ? Fuel pressure I will ask about that.
Cold starts are generally non issue with fuel pressure as the injectors are cycled for rich mixture until engine warms up.

Does it idle rough when you restart with engine warm? It may also be a faulty engine coolant temperature sensor. Engine should be running rich when started cold and someone lean when starting warm.


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
6 Posts
Discussion Starter #9
Here is something I forgot. I cannot put gas while the car is on because it would shut off. Yes I know u are not supposed to do that. But I was able to do that in the past with this car and others. I no longer do that but wasn’t sure if that was something still related to the crap canister.
 

·
Registered
05 camry 07 tacoma
Joined
·
3,004 Posts
Tegra- can you clarify the no start condition.
Does engine crank when you turn ignition switch on and not start or is it a matter of no crank no start?
 
1 - 10 of 10 Posts
Top