Toyota Nation Forum banner

121 - 127 of 127 Posts

·
Registered
2016 Avalon Limited
Joined
·
1 Posts
I have a 2016 Limited Avalon with 31,000 miles and it has started doing this last month. One reboot and I reset the settings. Then yesterday it happened twice and this morning three times. This is crazy!!! It is happening every time I get into the car now. Noticed if I try to plug in an address for navigation that it will reboot and lose what I put in. Reentered address, reboot, reentered, reboot. So this definitely triggers it, but I don't us the navigation just going around town here and there. My android phone does not affect it. A head unit or replacing the radio, I was quoted at least $800. I will try the update suggested here and removing my ipod that is connected.
 

·
Registered
Joined
·
243 Posts
"I will reset again and try turning off my bluetooth." Good luck. We got the same song and dance from our dealer for our 2017 HiHy Limited Platinum. blaming Apple and Samsung phone OS updates that were incompatible with enTune. We resorted to turning our phones off while driving. Only a new head unit solved the issue for us.
 

·
Registered
Joined
·
4 Posts
Thank god I found this site and thread. I am hoping that removing all photos from my contacts works. It is so frustrating and the dealership simply said that the radio needs to be replaced to the cost of $1000 to $2000. And to see on this thread, that that won't even fix the issues. I am glad I lost it and told them no. Fingers crossed the lack of photos works for me.
My dealer quoted me $4000 back in Jan 2020 after they said they did a software update which I can't verify they did.. I haven't figured out how to get the rebooting to stop. My bluetooth isn't connected so I can't unconnect it. I think I do have a couple of pictures in the contacts I'll remove and see if it finally does something. If not, I'll see what else I can do.
It's like it lost its memory and trying to get it back...
 

·
Registered
Joined
·
4 Posts
$4000 USD ?!!???? LOL...wow. legal thieves... With that you can have some amazing sound system. Honestly you are not missing much without the stock head unit. Put a nice sounding system, and you will regret not doing it sooner :)
Do you have any suggestions? Sorry I didn't reply to this sooner - my dad passed away in Nov so I put this on the back burner plus I have CD's that work just fine. Plus I'm leery of someone removing the dash and really screwing it up. I will be researching whatever is recommended. Thank you!!
 

·
Registered
Joined
·
37 Posts
Do you have any suggestions? Sorry I didn't reply to this sooner - my dad passed away in Nov so I put this on the back burner plus I have CD's that work just fine. Plus I'm leery of someone removing the dash and really screwing it up. I will be researching whatever is recommended. Thank you!!
I am sort of looking around at a head replacement. There are many choices. They get divided into two categories: Head units that support Apple's Car Play and/or Android Auto, or head units that are actually Android based units that essentially are a tablet that supports everything you can do on your phone.

It's a complicated choice and I offer two things. First, this thread has a lot of good information about after market head units: 3rd gen Highlander Apple CarPlay Upgrade

And second take a look at the Crutchfield website: Find what fits your car - Crutchfield

They have a lot of good information about fit and features that are vehicle specific (Note: I have no association at all with Crutchfield, except as a previous satisfied customer).
 

·
Moderator
2014 Highlander LE
Joined
·
8,001 Posts
Do you have any suggestions? Sorry I didn't reply to this sooner - my dad passed away in Nov so I put this on the back burner plus I have CD's that work just fine. Plus I'm leery of someone removing the dash and really screwing it up. I will be researching whatever is recommended. Thank you!!
If you are having a shop install things, and it sounds like you should, I would buy the gear from some other reputable electronics seller. Crutchfield is overpriced for just the parts. People pay Crutchfield prices as they have DIY install info and support.
 

·
Registered
Joined
·
1 Posts
OK everybody. My system shut down and rebooted multiple times. Turn on brights. reboot. Put in reverse at night backing up trailer. reboot. Talked to my nephew, expert Toyota technician and he said with no check engine warning lights. it had to be a weak battery. Come to find out terminal on 1 year battery was covered in white powder. Cleaned and sanded terminal and wire connector, problem solved. DO NOT pay for upgrade. My 2014 HL has never had any upgrades.
My issue is with a 2016 Avalon XLE. Your post is the first I have seen to reference corrosion on the battery terminal. I have gone through a lot of attempted solutions with nothing really working except turning off bluetooth on the phone and removing the phone from the navigation system. At that point the system (radio, etc.) works flawlessly. I did consider the corrosion a possible issue but since the main discussion in this forum centers on the iphone variations, I have yet to clean the positive terminal. The irony is my problem is with a late model flip phone with no photos and very few contacts. Is your solution of cleaning the battery terminal still working? Has corrosion built up again necessitating cleaning again? Thanks for the post.
 
121 - 127 of 127 Posts
Top