Toyota Nation Forum banner
1 - 8 of 8 Posts

·
UNDUL8
88Camry/87Starion
Joined
·
19 Posts
Discussion Starter · #1 · (Edited)
changed the fuel pump in the Camry..

now what it ran

but got progressively worse as it ran..

are my injectors and stuff clogged?

will idle but if I push the throttle any it just dies..

drained tank

changed pump and underhood filter.

any ideas?

air flow sensor bad?
 

·
Premium Member
Joined
·
6,403 Posts
The engine did not run before the fuel pump change?

If a MAP sensor try unplugging it as the ECU may reset to a default mode and the engine run somewhat better.

Might also be the throttle position sensor.

Rarely do the injectors become so plugged the engine will not run in neutral if throttle pushed.
 

·
UNDUL8
88Camry/87Starion
Joined
·
19 Posts
Discussion Starter · #4 · (Edited)
did this post on my way out today

forgot to mention

car ran before parked 4 years ago...


the intake tube is in poor shape but I seems to seal and had no holes..

I do have a vac leak. it is to a thermo sensor near the radiator hose.

I thought
i read somewhere that this had somethin to do with the cold start injector

I also forgot to state this is an 88 do they have map sensors?

I know it has a MAS/MAF...

Imma try and find another thermosensor...

also someone explained to me that fuel tanks needed to be sealed to creat fuel pressure... but I had the port open for the gauge sender and had pressure but maybe not enough? i wanted to get everthing going before I did all the seal ing up of things in case I neede to tear it all down again..

but heck.. I'll close all the holes up can't hurt.

any other Ideas?

Thanks for the replys!
_Drew
 

·
JUST RE ENGINEER IT
98 Prizum
Joined
·
2,983 Posts
the tank sealing bit is a crock, there is a pump in the tank that makes pressure, now that it sat the pump, tank and filter may be trashed because gas turns to acid and eats everything up, start hunting for a junkyard car with a gas tank
 

·
UNDUL8
88Camry/87Starion
Joined
·
19 Posts
Discussion Starter · #6 ·
the tank sealing bit is a crock, there is a pump in the tank that makes pressure, now that it sat the pump, tank and filter may be trashed because gas turns to acid and eats everything up, start hunting for a junkyard car with a gas tank
thought so.. but I am making pressure.. and I think the new filter clogged up
with gummy yummy gas!! :barf:

I;m gonna plug the vac line and blow the filter loose a few more times and see what I get...

sat for a long time... slurpy noise may be crap on the sock on the used pump

so if I don't get it with a little more running and cleaning the filter I'll pull the tank back out and pressure wash it.
 

·
UNDUL8
88Camry/87Starion
Joined
·
19 Posts
Discussion Starter · #7 ·
okay so I figured it out.

but I need help fixing it.
fuel pressure regulator or return line is clogged.

I have no idea where the FPR is.

anybody help me out here.


the pump sock is in that cup but that cup stays empty because the fuel isn't coming back to it.
 

·
UNDUL8
88Camry/87Starion
Joined
·
19 Posts
Discussion Starter · #8 ·
sound the FPR but that's a tight squeeze, lol

thanks for all the help

I think the FPR is bad I'll know more tomorrow.
 
1 - 8 of 8 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top