Toyota Nation Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
the error code is P2445 Secondary Air injection system pump stuck off. Bank 1.

what do i do i need some help my mechanic even said that he has never heard of that and was going to do some research but i was wanting to know if anyone on here could help. let me konw.
 

·
Premium Member
Joined
·
6,403 Posts
Does this engine have an air injection pump?

Air pump fuse, vacuum hose, air pump assy, open circuit in air pump assy, air injection system piping, pressure sensor, open or short in pressure sensor circuit, ECM
 

·
Registered
Joined
·
3,671 Posts
the error code is P2445 Secondary Air injection system pump stuck off. Bank 1.

what do i do i need some help my mechanic even said that he has never heard of that and was going to do some research but i was wanting to know if anyone on here could help. let me konw.
Could be a bad fuse, vacuum lines, or the air pump itself.

Did you recently install an after market air intake system? If you did, check all vacuum hoses and connections, and make sure the lines are not kinked.

If you do not have an after market intake system, check the air pump fuse, 50A, in the engine compartment. The fuse location is on the back of the fuse cover in the engine bay. Check all vacuum hoses leading from air switching valve to VSV and pressure sensor. If the fuse is blown, replace it, and reset your ECU by disconnecting your negative battery terminal and then turn on your lights for 30 seconds. If the code comes up again, you likely have a short in your system.
 

·
Registered
Joined
·
6 Posts
Discussion Starter #4
i have put a K&N Typhoon system on it and i was wanting to know if someone could come up with a diagram of how the vac hoses should be and another thing when the diag. was done it said it was stuck off. also all the hoses are hooked up right and there are no kinks
 

·
Registered
Joined
·
3,671 Posts
i have put a K&N Typhoon system on it and i was wanting to know if someone could come up with a diagram of how the vac hoses should be and another thing when the diag. was done it said it was stuck off. also all the hoses are hooked up right and there are no kinks
Was your fuse ok? When you put in your K&N, did you have to remove any smog filters? You may have to end up disconnecting the big hose that joins the intake from the air pump and cap the intake with a cap and put a breather on the air pump. But check the fuse first.
 

·
Registered
Joined
·
6 Posts
Discussion Starter #6
the fuse is ok and from what me and my mechanic can tell the vac. tubing is all conected right and im still getting the damn code
 

·
Registered
Joined
·
6 Posts
Discussion Starter #8
i dont want to have to do that cause im going to be getting rid of this car soon to get a bigger car cause i just had a kid and the girl im with has a 2 year old already
 

·
Registered
2005 Toyota Tundra
Joined
·
2 Posts
Help

So, I have that code along with P0418 (which is a bad relay). I have checked the relay (because is has a window), and I think it's ok... I don't know how to take the relay out... If someone could help with that, it would be great.

I looked up and saw that it might be the secondary air intake fan and pump (because it makes a weird humming when it starts) and I need to know what parts I need to get. The dealerships in my area aren't helpful unless I take it in and pay for them to tell me.
:frown:
 
1 - 10 of 10 Posts
Top