Toyota Nation Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter #1
My 96 toyota corolla dx 1.6l has recently been giving me idle issues as well as sputtering while in motion. It starts up just fine and it stays running, although when idling while in motion the engine sputters and once I give it gas the car snaps out of it. Only when I take my foot off the accelerator does the sputtering happen.It feels almost like a fuel issue or a vacume problem. The check engine light is on and the fault codes are 0120, 0125, 0141,and 0401.
 

·
Premium Member
1994 Corolla DX
Joined
·
4,173 Posts
You're at a point where you have enough trouble codes that you'll have to figure out if the codes are REALLY set by the sensors, or if you have a broader issue (say, wiring harness). Some of the codes you have we see on this forum quite frequently but the TPS code is somewhat unusual.

P0120 - Throttle Position Sensor
P0125 - Coolant temp sensor
P0141 - Rear O2 sensor
P0401 - EGR vacuum switch valve

These sensors can all be tested. Start there before replacing anything. See this sticky to understand what options (free and paid) you have to access repair manuals that tell you the specs and tests: https://www.toyotanation.com/forum/showthread.php?t=814401
 

·
Senior TN Member
Porsche
Joined
·
7,508 Posts
When you've got that many errors, it's unlikely that they ALL failed at once.

Common issue that causes multiple errors is bad grounds to ECU. Sensors use these as grounds and if even single ground is bad, EVERYTHING that uses that ground will malfunction. All sensors and ECU itself will act flaky. Grounds are E1, E2, E3, etc. . Unbolt them, sand both sides of ring-terminal and mating surface on chassis. Reinstall, torque nut to proper spec, slop grease over entire assembly to keep corrosion at bay.
 
1 - 4 of 4 Posts
Top