Toyota Nation Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
65 Posts
Discussion Starter #1 (Edited)
!i!i!i! Expert advice desperately needed, please !i!i!i!

Hello all!

(I've searched on my weird problem and didn't find anything about it)

I have a 92' Camry LE (--> Gen 3<--) with only 62,000 KILOMETERS on it (around 39,000 miles).

I appear to have a weird noise coming from my dashboard. It goes on only when I'm on the highway, with overdrive on (actually never really tried with o/d off), and I accelerate so that RPM nears 3,000. It comes from the left of the dashboard, to the left of the gauges (close, it's inside the dash, not in the engine bay)... It sounds like a drill motor or any small little motors. It didn't bother me too much at the beginning but now it does that anytime I accelerate after reaching 100 km/h (60 mph)...

I'd like to get your opinion on this please, this just can't be a unique problem I would be the only one having... And now it's being a real pain in the a$$...
 

·
Registered
Joined
·
30 Posts
Your rpm nears 3000 going 60? That is unusual. With the O/D in it should near 3000 going 85-90 on the highway when your on the overdrive gear.
Something doesn't sound right with the transmission.
 

·
Registered
Joined
·
65 Posts
Discussion Starter #3
actually its when I'm on a cruising speed of 60 and I accelerate to (dont know how to say this in english) shift-go before the person in front of you by going left and accelerating- people. So it's when I suddently go OVER 60 mph... Please help me out!
 

·
Registered
Joined
·
65 Posts
Discussion Starter #4
/bump - this is not funny, I know you probably haven't ever heard of anything like this but I'd like your opinion on this so I can fix my problem ASAP!
 

·
Registered
Joined
·
65 Posts
Discussion Starter #6
Thanks for your advice but I need other people's opinions, please, this is really bad and I dont want to go to a Toyota dealer for this...
 
1 - 6 of 6 Posts
Top