Toyota Nation Forum banner
1 - 10 of 10 Posts

·
Where's my boomstick?
Joined
·
2,528 Posts
Discussion Starter · #1 ·
OK...first off...

For awhile now my 91 Camry 3sfe auto has been behaving strangly under moderate to hard acceleration, like when pulling out into traffic. Ill hit the gas, and between the shift from either 1st to 2nd or 2nd to 3rd (not sure which) the engine just seems to die. The RPMS will be normal then they will drop down a couple thousand, then it will spike up kinda high, then drop down, then it will spike and then i think it shifts and accelerates normally. It doesnt happen everytime, but it seems to be more frequent once the engine warms up. Any Suggestions?

Second...
Lately i have been getting good puff or two of smoke on cold starts. Blue in color, and it goes away after >10seconds. Last time I pulled the spark plugs, they had a coating of oil on them, so I assume my valve seals are going...is this correct? And if so, does anyone know what price range it is going to be to get this fixed?

EDIT....just realized that i posted this in the wrong section...someone wanna move it to Tech for me?


Thanks and sorry for the uber long post, but i didnt know what else to do.
 

·
Where's my boomstick?
Joined
·
2,528 Posts
Discussion Starter · #4 ·
celiboy said:
maybe your throdle body needs cleaning, try a tune up as well...as for the blue smoke, i'm guessing your burning oil.
the throttle body is spotless, and I know im buring oil, the question is where and why. but thanks anyway
 

·
Where's my boomstick?
Joined
·
2,528 Posts
Discussion Starter · #5 ·
if you guys need me to descibe it better, let me know. I really would like to have an idea of whats going on.
 

·
Grenaded piston
Joined
·
7,447 Posts
Stevethecleric said:
Lately i have been getting good puff or two of smoke on cold starts. Blue in color, and it goes away after >10seconds. Last time I pulled the spark plugs, they had a coating of oil on them, so I assume my valve seals are going...is this correct? And if so, does anyone know what price range it is going to be to get this fixed?
Yeah your valve seals are bad.

The seals themselves are about $120 from a Toyota dealership. Theres 16 seals (8 intake, 8 exhaust).

I got a quote from a local dealership for $650 or $750 (I forget) to replace the valve seals. No thanks. :)

I was going to replace the seals myself, but never got around to it.
 

·
Where's my boomstick?
Joined
·
2,528 Posts
Discussion Starter · #7 ·
^ thanks man. no ideas on the first problem?

at the high of a cost, i think im just going to drive the car into the ground and save some dough and look for a gen3 camry or maybe a celica. i dunno...only time will tell.
 

·
Grenaded piston
Joined
·
7,447 Posts
Stevethecleric said:
^ thanks man. no ideas on the first problem?
No idea whats going on. Never had that problem. Have you checked the tranny fluid to make sure its not low or too full?

When I stomp on the gas it downshifts and the rpms rise towards redline or till I let off the gas. Then it shifts into the next gear.
 

·
Banned
2006 Lincoln Zephyr
Joined
·
1,289 Posts
GEEZ, the dealership is a ripoff. For 750 you could swap to a brand new engine with more hp, less miles, and actually save money.
 

·
Where's my boomstick?
Joined
·
2,528 Posts
Discussion Starter · #10 ·
^yeah that was my thought exactly, I got a quote on a 3sge with tranny for $550. If i put it in myself, it would be cheaper.

this is the car's second transmission, first went out in october 03, this one is a rebuild. when i put it in i made sure it was flushed and filled right, and it still looks good now so i dont think its that.

The only idea that i had was possible something with fuel delivery, or the injectors, since it only happens in the higher rpm ranges. is this a plausable theory? and if so, what should i check?
 
1 - 10 of 10 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top