Toyota Nation Forum banner

1 - 15 of 15 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter · #1 · (Edited)
Attention All Avalon Owners - Flickering Lights - Info

Greetings everyone!

I recently purchased a 2004 Avalon XLS (with 70k) and noticed the headlights and interior lights flicker. The flicker is not related to RPM speed - when the RPM's increase, the flickering remains the same - no change. Also, when the car is off, the lights do not flicker. The flickering is only present when the car is running and is most apparent at night and hardly noticeable during the day. This condition never goes away - doesn't matter if the car has been driven 50 miles - flicker still present.

I've researched this issue online(forums and google) but have come up empty. The previous owner replaced the battery a couple months ago with a Toyota 84 month battery. Before I purchased the car, I took it to the local Toyota dealership to have it inspected. Everything passed including the charging system.

I replaced the positive battery terminal(due to corrosion) and thoroughly cleaned the negative terminal. I also checked the connections at the alternator and cleaned the 2 endpoints(grounds - that attach to the frame and engine) of the negative cable.

I contacted a couple Toyota dealerships in the area to see if there were any TSB's for this issue and there weren't. They also stated they had never heard of this problem (which I find hard to believe).

Any help would be greatly appreciated!
 

·
Registered
'00 XLS, '05 XLS
Joined
·
372 Posts
this is the same problem that witness just posted in a thread with 2001 electronics topic. it was present in the gen 2 avalons. somewhere way back in the avalon forum was a lengthy post on the topic. it is caused by one of the sensors that draws alot of current. i dont think there is anything that can be done about it.
 

·
Registered
Joined
·
32 Posts
I previously had a 2003 with that problem. It never really caused any issues, but was an annoyance. I had it 2 years and sold it... the new owner still has it. It's worked fine with no issues, just flickering. Not sure if anything can be done to it. :confused:
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #4 · (Edited)
Actually, the "2001 electronics" post stated the flickering stopped after awhile. Unfortunately, mine always flickers. What I meant by I came up empty in searching the forums and google was that I was unable to find a solution (I have read many posts both here and others).

I did read about the air/fuel sensors causing the problem - are there any work arounds?

I have a hard time believing that all gen 2 Avalons have this problem considering they're $30,000 vehicles (it'd be understandable with a Ford or Chevy - heck, even my 1993 Saturn SL2 with 365,000 miles doesn't do that!). If this is true, shame on Toyota! The least they could do is create a TSB. It probably doesn't help I come from a quality engineering background.

Something interesting, before I purchased the Avalon, I test drove a 2001 Camry XLE (V6) that also had a flickering problem(much worse than the Avalon - one of many reasons why I didn't purchase the Camry). Could it be that this problem only occurs on V6's?

Has anyone brought their Avalon or Camry to a Toyota dealer to have this problem diagnosed?
 

·
Registered
Joined
·
11 Posts
I, too, have this problem. I just purchased an '03 Avalon, and have the flickering as well. It's barely noticeable, but it's there.

One thing I've noticed is that there's an every so slight click noise (when I start the car cold) coming from the serpentine belt. As soon as the car has warmed adequately, that click goes away, but while it's clicking, the flickering is almost in complete tandem with the noise. But, when the noise goes away, the flickering does not. I wonder if it's something to do with the serpentine belt, or perhaps the belt not rotating quickly enough to provide stability to all the electronics?

I'm not a huge mechanic ... I'm sure this sounds so incredibly professional! :D
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #7 · (Edited)
Interesting.

Does anyone know if the flickering goes away when it's nice and tosty warm outside(I'm in Minnesota)?

I think I'm going to try to disconnect the air/fuel sensors(each side of the exhaust manifold) to see if the flickering stops.
 

·
Official Member
97 Avy XLS
Joined
·
92 Posts
Lights flickering usually means either a bad connection, bad ground, or something drawing excessive current. If after all connections are ruled out you need to check out different systems using an ameter to see if something is drawing more current than it is suppose to.
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #9 · (Edited)
I just got done unplugging the 2 air/fuel sensors and the flickering stopped! I then contacted a local Toyota dealership and spoke with a service advisor. I explained the situation and he had heard of the problem but was going to get additional information regarding a possible fix. Corporate had better come up with a fix!

Stay tuned! I hope to hear back sometime today!
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #11 · (Edited)
Yup, there's a post about this issue dated 12/24/05 regarding a possible software fix. Let's hope Corporate did their homework! Since it appears this problem is present in Avalons and Camrys, Toyota should own up to it and at the very least, issue a TSB!

Toyota is already in the hot seat regarding the class action oil gel/sludge engine problem. The last thing they need to do is open another can of worms by ignoring this issue!
 

·
Registered
98 Avalon XLS
Joined
·
5 Posts
I have the flickeritis too...

I noticed the last post was almost 2 months ago.

I bought my 98 Avalon XLS on 2-11-07, and noticed the int.& ext.lights flickering,
the first night.
I got this car from a Toyota dealer (uncertified due to age.)
She now has 62, 600 miles on her.

I took her back for a free look, and the first diganosis was the ALT.

They replaced the ALT. for free and the flicker is still present.
Then, I was told to bring her back a few days later, so the shop foreman could take a look at her.

The charging system is okay. Battery, (of coarse the ALT) and ALL connections, grounds and relays too.

Turns out, the foreman called the Toyota tech. assitance line, and he was told, Toyota is
aware of the problem, and for now...it's a "normal condition"....WTF!!!!!!!
I've heard of the A/F sensor possibilty as well...and brought that to the foremans attention, and for now...NO software updates.

So.....gotta live with it...for now.
Thanks for reading this.
 

·
Registered
Joined
·
11 Posts
Thanks for the update on this. Yes, it is a quite frustrating problem, but I guess I'm getting used to mine. It seems worse when the car is first running, but it gets slightly better as it warms up.

I just did a trip from Wisconsin to Florida and back, and that was on my mind, believe me! While I'm not thrilled to see that it's considered a "normal" issue, I'm grateful that it's not yet another problem that needs to be fixed.

Perhaps we'll all get lucky some day and they'll solve this problem, right after global war and hunger. :rolleyes:
 

·
Registered
2011 Sienna SE
Joined
·
24 Posts
Same flickering issue here with my 2nd Gen Avalon. I already checked connections, cleaned terminals, and all sorts of things just checking it out. I was about to replace the alternator "just because" until I read this thread. I guess I need to read up! Thanks TN.
 

·
Registered
98 Avalon XLS
Joined
·
5 Posts
Normal condition???? Yeah, right.

As I stated in my post #12 above, Toyota is aware of the issue, and call it a
"normal condition".

If it's a "normal condition", then why don't ALL Avalon's have this light flickering issue???
I'm sure Toyota knows why some do it and some don't.

Perhaps(or most likely), some of the electrical components, relays and sensors, etc., come from different vendors, and the flickering Avalon's have the weakest components.
Well.... at least I got a free alternator when they tried to fix the flicker.:D

I'd sure like to know what percentage of Avalon's have this flickering issue.
 
1 - 15 of 15 Posts
Top