Toyota Nation Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
21 Posts
Discussion Starter · #1 ·
Daughter came home for lunch and when she went to leave no start. Turns over but would not start unless u worked the gas pedal. Used my innova Bluetooth scanner and had no codes.

My thoughts where idle air control value or maybe throttle position sensor. So I removed the right side throttle body to make it easier to remove the iacv. Got it apart ant it was very dirty cleaned with b12 relubed the bearing on the valve shaft and reinstalled.

Disconnected the battery and turn the key to the on position to clear the computer. So it could relearn the iacv. Upon starting idle was high at 1800rpm. Drive it for a few miles and now everything is fine.

Hope my problem doesn't come but, however I am glad I didn't waste money throwing parts at it. Posting with hopes it help some one else out. 216k and going strong again.
 

·
Registered
Joined
·
21 Posts
Discussion Starter · #3 ·
I sprayed the b12 then us blue shop towels and long needle nose pilers to soak up the excess and wipe the carbon off. As I am not a big fan of running a lot of the liquid through the motor.

Didn't look at the egr but that may be a next week project as it was getting late. Need to do a little searching here and find out the procedure for removing and cleaning.

I am just glad I got it up and going and only expense was a $3.99 can of b12.
 

·
Registered
2001 Focus + Avalon
Joined
·
26 Posts
Mine does this from time to time, usually the next day after a rain.
About once a month. You almost have to force it out of a spot by continuing to give it gas, and after 20 seconds or so... you are good.
 
1 - 6 of 6 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top