Toyota Nation Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
38 Posts
Discussion Starter · #1 ·
For the past few weeks I have been hearing a noise - it's hard to describe, kinda whining - from my steering wheel/column. It's been getting louder and is starting to irritate me. I have the haynes manual and I plan on tackling it once I finish up my rear strut/spring replacemanet. I'm guessing something needs to be greased?

Anyone have this problem before?

Oh, duh, car is a 99 camry 4cyl. auto.

Thanks all.
 

·
Banned
Camry / 2WD Pickup
Joined
·
601 Posts
[email protected],

If it's not the belt, it could be a u-joint (IIRC) that needs lubing. I had a similar problem on my Gen 1, years ago. Your Haynes should be able to help you.

Hope this helps!
 

·
Registered
Joined
·
9 Posts
When doing Csaxon's fix use dielectric grease, thats what Toyota gives us for this problem. Silicone spray also works but doesn't seem to last as long. The boot is a REAL common problem that is common on ALOT of Toyotas, especially `Camry. Noise is usually worse when its really cold outside.
 

·
Registered
Joined
·
38 Posts
Discussion Starter · #7 ·
Thx all. I wonder if it's my belt coz I tightened my belts coz I had an AC noise and the suggestions was tighten the belts to stop the noise.

Didn't work!

Turn out it's the common crappy AC compressor. But I left the belts as is, and that's when the noise showed up. I'm gonna loosen my belts back to where they were, and if that doesn't fix it, I'll try csaxon's fix.

MrApollo, what was the fix for your belts? Replace? Adjust?

Thx all - csaxaon, gr8hunsy.
 
1 - 7 of 7 Posts
Top