Toyota Nation Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
where is the Bank 1, Sensor 1 located on a 2003 toyota tacoma 4wd v6? How many sensors are there? Got the P0031 code. Any help is appreciated.
 

·
Registered
2002 Tacoma 4x4
Joined
·
77 Posts
Here are some links that should get you on your way. I would go with OEM Denso sensor by the way, aparently they cause the least amout of trouble.

http://www.tacomaworld.com/forum/1st-gen-tacomas/19548-replacing-o2-sensor.html

http://www.lieblweb.com/tacoma/Mechanical/O2Replacement/02Replacement.html

Im sure you could find much on this web site as well, but these are just some quick links i had from when i did mine. Really watch out for those nuts though it could be rough. When I did mine the nuts where literally rusted away to nothing, just enough to make it a pain in the ass to come off, also the nuts are a very uncommon tread can be hard to find. Good luck.
 

·
Registered
Joined
·
4 Posts
Here are some links that should get you on your way. I would go with OEM Denso sensor by the way, aparently they cause the least amout of trouble.

http://www.tacomaworld.com/forum/1st-gen-tacomas/19548-replacing-o2-sensor.html

http://www.lieblweb.com/tacoma/Mechanical/O2Replacement/02Replacement.html

Im sure you could find much on this web site as well, but these are just some quick links i had from when i did mine. Really watch out for those nuts though it could be rough. When I did mine the nuts where literally rusted away to nothing, just enough to make it a pain in the ass to come off, also the nuts are a very uncommon tread can be hard to find. Good luck.
Thanks for the links, I'll try this information out to clear my check engine light with the same code too.
 

·
Registered
Joined
·
4 Posts
Update: Hey guys, I changed out the front o2 sensor and the check engine is gone. Thanks for the tips, it surely guided me down the right path.

The job was pretty simple. :thumbup:
 
1 - 6 of 6 Posts
Top