Toyota Nation Forum banner

1 - 12 of 12 Posts

·
I'm a NOOB at <3
Joined
·
135 Posts
Discussion Starter · #1 ·
Hello Fellow Toyota drivers....:D

Well I have been changing my oil every 3k miles regularly....and yesturday when I did the oil change I noticed that when I was driving my oil light ( the little lamp thingy with the drip, red color) came on. And it was strange cause I just changed the oil and I never had any problems like this. I have a V6 1MZ-FE engine on my 1997 Camry. The odd part is that it constantly comes on and off as I rev the engine above 1k rpms...when it's a little below that the light comes on and when I press the gas it goes away primarly above 1k. I'm thinking it could be oil pressure dropping. Does this error read any other oil levels besides the oil in engine?
 

·
Registered
00 Camry 5sfe, 91 Je
Joined
·
38 Posts
Maybe a week oil pump or it could be the sludge issue,(not that I think its a big issue).
but that sounds like a weak oil pump the more rpms will make more pressure and turn the light off, it also could be the sending unit for the oil pressure light. Have the oil pressure checked before you drive it and blow the motor up.
 

·
I'm a NOOB at <3
Joined
·
135 Posts
Discussion Starter · #3 ·
Also on the side note I did notice like the old oil that I just changed smelled a little like gas it had an achohol smell to it...could it be a bad injector?
 

·
I'm a NOOB at <3
Joined
·
135 Posts
Discussion Starter · #4 ·
vwsteve said:
Maybe a week oil pump or it could be the sludge issue,(not that I think its a big issue).
but that sounds like a weak oil pump the more rpms will make more pressure and turn the light off, it also could be the sending unit for the oil pressure light. Have the oil pressure checked before you drive it and blow the motor up.
Thanks! :D
 

·
Registered
2002 4Runner
Joined
·
152 Posts
It doesn't measure anything but oil pressure in the engine. Of course get it checked out before you might cause damage. How many qt of oil do you put in when you change it? If you are not putting 5 whole quarts in of the correct weight (5W30), then that might cause the light to come on as a low oil level happens when you step on the gas, the oil pump pumps more oil, and it will make the oil level drop in the oil pan, causing pressure to drop, and causing the light to come on. If not anything you may have a bad oil pressure sensor located on the engine block on the right side
 

·
I'm a NOOB at <3
Joined
·
135 Posts
Discussion Starter · #6 · (Edited)
stir_fry_boy said:
It doesn't measure anything but oil pressure in the engine. Of course get it checked out before you might cause damage. How many qt of oil do you put in when you change it? If you are not putting 5 whole quarts in of the correct weight (5W30), then that might cause the light to come on as a low oil level happens when you step on the gas, the oil pump pumps more oil, and it will make the oil level drop in the oil pan, causing pressure to drop, and causing the light to come on. If not anything you may have a bad oil pressure sensor located on the engine block on the right side
Actually I have been putting a full 5 quarts all the time....though I have used 10W30 for the past couple of years and I had no problem with it at all until now...When I had gotten my lower control arm buschings replaced my friend "the mechanic" told me that my valve cover underneath the intake throtle body was leaking oil very little...I'm taking it to my friend tom I will let ya'll guys know how it goes....

Thanks for the replys!
 

·
Registered
Joined
·
6,173 Posts
Have the tech remove the oil sending unit and temporarily install an oil pressure gage to check the actual pressure. This will eliminate the sending unit and the gage on the dash as possible causes. Do this very soon. If it's low, the problem could be a bad oil pump or bad engine bearings. If it's a bad pump, that can be replaced. If it's bad bearings, then it's time for a new engine. Don't drive around will low oil pressure until you know the cause. You could be destroying an otherwise healthy engine.

Mike
 

·
Moving Forward
Joined
·
3,144 Posts
I agree with Mike get it checked by someone or yourself witha guage in the place of the sending unit. As long as the pressure is where it is supposed to be according to Toyota specs then more than likely it is jsut the sending unit. However like Mike said if t is the oil pump you can fix it. If it is bearings then time for a new engine or major rebuild.
 

·
Dave's
Joined
·
1,946 Posts
This is just 'heard-tell' so it may not be factual but supposedly incorrect or defective filters can cause this problem too.
 

·
I'm a NOOB at <3
Joined
·
135 Posts
Discussion Starter · #12 ·
Just a heads up on my oil light comming on... I took my car that same day to my friends shop and he hooked it it up too a manual gauge and apparently he told me that the pump was working fine and no noise was comming from th engine, so he hooked me up with a sensor and I will pick it up on monday.....:D. I also went ahead and let him change my oil pump gasket and my timming belt and water pump and other seals that need be so I got the hook up!
 
1 - 12 of 12 Posts
Top