Toyota Nation Forum banner
1 - 9 of 9 Posts

· Registered
Joined
·
268 Posts
Discussion Starter · #1 · (Edited)
Alright... After dealing with a bad patch on my cracked radiator (had to fill it up twice a day... lots of turnpike driving). I finally replaced it (Easiest shit in the world... don’t you ever pay someone to do it).

So here is the problem... I find every now and then my overflow bottle for the radiator is steaming up. And every time it happens all the coolant evaporates from the overflow bottle... It happened first after I just installed it and took it for a test run. So I wrote it off to breaking it in... Then two more times that week on the turnpike… Then it was cool for a while but it happened again after an hour road trip, so it has my concern again...

So what does the nation think? Its still breaking in or what?
 

· Registered
Joined
·
268 Posts
Discussion Starter · #5 ·
The radiator cap :eek:... Trust me i wouldnt forget that... No i used the same old hoses, I checked them for leaks and they where straight.. But funny enough i checked it awhile ago and return hose at the bottom of the radiator is pretty soft and to make it worse "its closed". Like its bent in a way that the water cant really pass... And right above the bend is this rubber sleeve you can move along the hose... So i'm going to try and use that sleeve until i can make it to autoparts this weekend...
 

· Registered
2002 Camry
Joined
·
2,241 Posts
Maybe you answered your own question, the hose is squished and water cant pass? Its collapsed. But usually it is the UPPER those that collapses. Also you mention nothing about the temperature gauge going up too.
Im hoping it is just the worn out hose causing the problem because hopefully it is not a blown head gasket, because this is what it sounds like. BUT other causes, thermostat stuck shut (but your temperature would be sky high) or some kind of cooling system restriction, like maybe your new radiator is defective.
 

· I work on euros.
96 Toy Camry Sport
Joined
·
207 Posts
funny that only marc mentioned the thermostat. I've seen stats stuck shut and it didn't blow steam or anything, just came back to the shop three times for low coolant after the coolant in the block vaporized.
 
1 - 9 of 9 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top