Toyota Nation Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter #1
hey everyone

so my rav is throwing codes to me on the car reader and i keep gettin P0500, as the speedomoter does not work, and does not record mileage to the dash ONLY, since i have a 5 speed nothing else on the car is affected and/or nothing else with the cluster is wrong either, ive talked to toyota and its not the sensor on the transmission as thatd be other problems! how can i take out the cluster and check the wiring or find the spots? any easy fix or solutions im really stuck and i need to get the car inspected within the month im so stuck on these problems

and a P1135 now ive done google search but i cant find any hard facts on this besides the 02 / f/a sensor they call it?!? i dunno where its located before or after the cat? is there more then one that needs to be replaced?
 

·
Registered
Joined
·
8 Posts
Discussion Starter #2 (Edited)
hey sorry i forgot to post that the year is a 2002 rav4, 5 speed, 4 cyl , 2 wheel drive


hope this helps with anyone being able to give any information and help
 

·
Registered
Joined
·
8 Posts
have you checked your fuses and relays?
the other code sounds like its pointing to the O2 sensor which is screwed into the exhaust.
 

·
Registered
Joined
·
8 Posts
Discussion Starter #4 (Edited)
i changed the o2 sensor this morning but it was really an air fuel sensor but called the 02 it was bank 1 sensor 1, took abit of trying and twisting back and forth, but it never been changed in its life....

fuses and relays under the hood are perfect, im now in need of help with finding the VSS on my rav so i can get to changing that asap
 

·
Registered
Joined
·
8 Posts
The VSS (Vehicle Speed Sensor) is mounted on transaxle and contains a three pin electrical connector. Remove necessary components for access to VSS. Disconnect electrical connector at VSS...



they say to clean it first and then reset the ECU. if it comes back then replace it.
 

·
Registered
Joined
·
8 Posts
also what year is it? that makes a differance. mines a 1999 and you have to take the drivers tire off and the inner plastic wheel liner. there are two sensors and the vss is the farthest one and not fun to get to.
 

·
Registered
Joined
·
8 Posts
Discussion Starter #7
also what year is it? that makes a differance. mines a 1999 and you have to take the drivers tire off and the inner plastic wheel liner. there are two sensors and the vss is the farthest one and not fun to get to.
its a 2002 , 4 cyl, 2wd

the most ive come up with on the internet is that picture, glad you told me atleast where to look, im gonna be going back to autozone to return the o2 wrenches i borrowed, and look at the manual for this and see if anything clearer.... if the year is a big difference, well know soon :thanks:
 
1 - 8 of 8 Posts
Top