Toyota Nation Forum banner

1 - 15 of 15 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
Can anyone tell me what exactly a p1780 code is and how can i fixt it . The car is a 99 lexus es300 . Im having a hard time figuring it out ...

thanks
jose :confused:
 

·
Registered
Joined
·
937 Posts
A p1780 is a code for the neutral safety switch that is mounted on the tansmission. This switch basically tells the engine control computer what gear you have the car in. The code sets when it recieves conflicting signals from the switch, such as being in park and reverse at the same time. The switch or the wiring could be the problem. Its more likely the switch but its best to have it checked first. The switch runs anywhere from $150 to $250 depending on which type it is.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #3
by the way i had a wire that was pinched in the trunk and i fix it .... could that have caused the code to show up ....... it used to make my reverse light on the instrument panel light up and now it does not
 

·
Registered
Joined
·
937 Posts
It sure could. I ran into a similar situation on an LX 470. The computer thinks the car is in reverse and drive at the same time so it throws the neutral safety switch code since it cant possible be in both those gears at the same time.
 

·
Registered
2000 Lexus ES300
Joined
·
10 Posts
99lexus...How hard was it to fix that wiring problem on the tail lights? I just bought a 98 lexus that has the same problem. The trunk lid mounted lights don't work and it throws the same code. If you could give me an idea of where to look for that wire pinch, it may save me some search time. Thanks!
Good job fixing the problem by the way. Seeing this post saved me a lot of heartache. My wife was pretty discouraged about that check engine light.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #7
hey the pinch wire was by the side in the trunk ... there are wires running through a black protective plastic there i took that apart and went through all the wires mine was a white colored wire that was broken once i connected them again my check engine light went away and the car has been fine since them ... good luck ....
 

·
Registered
2000 Lexus ES300
Joined
·
10 Posts
I'm going to give it a try tonight. Hopefully it will be in a similar location. It seems like a common problem from my research. Thanks for the reply!
 

·
Registered
2000 Lexus ES300
Joined
·
10 Posts
I got in there last night and someone had just taped the wires together. I put a connector between the two that were broken and everything came on. The check engine light went off too. Thanks for the help!
 

·
Registered
Joined
·
4 Posts
I got in there last night and someone had just taped the wires together. I put a connector between the two that were broken and everything came on. The check engine light went off too. Thanks for the help!
Hi all,
I am new to this forum and I need all the help I can get.
I have a 2001 RX300 and recently I got a CEL with error code P1780. I took a stupid route to replace the PNP switch and rebuild the ECM without doing the diagnosis properly so I still get the CEL P1780 today. My guess is the PNP harness could only be the culprit now. Please let me know if you have similar problem and how to fix it.
Thank you.
 

·
Registered
2000 Lexus ES300
Joined
·
10 Posts
I don't know how the RX300 is, but with my ES300 it was the wiring harness that goes to the rear lights that are mounted in the trunk lid. The wires bend every time the trunk is opened and closed, so one of them had broken. When the wire broke, it caused the car to think it was in reverse and drive at the same time.
If your RX300 has lights mounted in the tail gate, I would have someone look at your rear lights to see if the reverse lights come on when you put the transmission in reverse. If they don't come on, then the problem is probably a broken wire in the light harness. Mine was obvious because someone had attempted to repair the problem by taping the wires together. The break was at a predictable location where the wires bent at every time the trunk was opened. Wouldn't hurt to make sure the light bulbs are all good too.
Hope that helps!
 

·
Registered
Joined
·
4 Posts
I don't know how the RX300 is, but with my ES300 it was the wiring harness that goes to the rear lights that are mounted in the trunk lid. The wires bend every time the trunk is opened and closed, so one of them had broken. When the wire broke, it caused the car to think it was in reverse and drive at the same time.
If your RX300 has lights mounted in the tail gate, I would have someone look at your rear lights to see if the reverse lights come on when you put the transmission in reverse. If they don't come on, then the problem is probably a broken wire in the light harness. Mine was obvious because someone had attempted to repair the problem by taping the wires together. The break was at a predictable location where the wires bent at every time the trunk was opened. Wouldn't hurt to make sure the light bulbs are all good too.
Hope that helps!
I will check this tonight.
Thanks for your help.
-Tai
 

·
Registered
Joined
·
4 Posts
I will check this tonight.
Thanks for your help.
-Tai
Hi 98Lexus_210K+,
I was out for awhile until today.
I checked and the reverse light is light up when I put the car in reverse.
I had also replaced the PNP switch with a brand new one but I still get the error code 1780. Note that the car is in very good shape (has only57K mi). I checked the wires near the connector and no damage there. Not sure what is now.
Thanks for reading.
:thanks:
-Tai
 

·
Registered
Joined
·
4 Posts
Hi 98Lexus_210K+,
I was out for awhile until today.
I checked and the reverse light is light up when I put the car in reverse.
I had also replaced the PNP switch with a brand new one but I still get the error code 1780. Note that the car is in very good shape (has only57K mi). I checked the wires near the connector and no damage there. Not sure what is now.
Thanks for reading.
:thanks:
-Tai
Finally I got my problem fixed I think. I got an ECU from Javoosi here in Katy, TX. It has been one week and no CEL yet. Knock on wood.
-Tai
:thanks:
 

·
Registered
Joined
·
1 Posts
Can anyone tell me what exactly a p1780 code is and how can i fixt it . The car is a 99 lexus es300 . Im having a hard time figuring it out ...

thanks
jose :confused:
[/QUOTE
Can anyone tell me what exactly a p1780 code is and how can i fixt it . The car is a 99 lexus es300 . Im having a hard time figuring it out ...

thanks
jose :confused:
hsjdjjeejd
Can anyone tell me what exactly a p1780 code is and how can i fixt it . The car is a 99 lexus es300 . Im having a hard time figuring it out ...

thanks
jose :confused:
h
Can anyone tell me what exactly a p1780 code is and how can i fixt it . The car is a 99 lexus es300 . Im having a hard time figuring it out ...

thanks
jose :confused:
I too was having similar problem. When ever the headlight were on and the car was driving (in drive gear) the engine light would come on throwing the p1780 code.

The solution posted below by other regarding the broken wires “is correct”.

I have attached images to where this problem is. I reworded them. I had a total of five separate wires that needed to be re-connected.

02C3092B-982B-47C6-A86D-1A6D2AB97492.jpeg
 

Attachments

1 - 15 of 15 Posts
Top