Toyota Nation Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Hi, i have 2008 highlander and my first issue was check vsc system is on and it has the check engine light and slippery indicator light on. Run it with obd scanner i got code p0793 (intermediate shaft speed sensor a circuit no signal). I just change the transmission intermediate shaft speed sensor along with the air filter also. I took it for the test drive and the check vsc system went back on along wit the check engine light and slippery indicator light went back on. Now is giving me a new code p2714 (pressure control solenoid "d' performance or struck off).? Should i change the solenoid that i think its inside the trans? Or should i just do a transmission fluid flush for now...? Thank you!
 

·
Registered
Joined
·
2,347 Posts
year/make/model/miles/engine/transmission/drivetrain/maintenance & accident history

If transmission is well maintained and ATF level full, troubleshoot the solenoid wiring harness, vehicle/chassis/drivetrain grounds, and/or replace the solenoid.

My well maintained accident/flood free '08 Toyota Highlander AWD non-hybrid V6 5-speed auto with 160k miles hasn't had your error codes but has had some easy to locate/fix rodent wiring damage and corroded harness connections & power/ground cables..... which caused a full list of codes that meant nothing. You either have nothing wrong and will chase your tail replacing sensors/solenoids/widgets and need to find the wiring issues. Or, you have everything wrong due to flood/accident/neglect and need to replace parts, or you have a bad ECU if all else tested well.

Did you test the sensor before replacing it either with real time scope data, or even bench test it?

Troubleshooting is more than reading codes and replacing parts.
 
1 - 3 of 3 Posts
Top