Toyota Nation Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
Just bought a 1995 Toyota 4runner with the 3.0 in it,here are the things I have done to it so far....
valve cover gaskets
radiator,water pump,timing belt,complete tune up,trans flush,filter,oil change,i cleaned and 6 injectors,im still having the problem of no power,I can take it around the block and I have to floor it just to get it back home.Max maybe it will get up to 25mph or so.


I also checked all 6 cylinders for compression and all 6 are roughly 180 or so.It starts up fine and idles good.


I also double checked the timing and its fine.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #2 (Edited)
I do have the tps off right now trying to test it.


just did the codes
14-ignition signal
21-oxygen sensor
24-intake air temp sensor signal
41-throttlw position sensor signal-I do have it removed right now
52-knock sensor signal
 

·
Soylent Green sales
rock crawler
Joined
·
12,801 Posts
Looks like you have your work cut out for you.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #4
I put the tps back in and found a broken wire,now the tps code and the knock sensor code are gone,still no power,might pull the cat off and see what happens
 

·
Soylent Green sales
rock crawler
Joined
·
12,801 Posts
The cat conv could be clogged, which will strangle the engine.
You might want to look into fixing the other error codes first.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #6 (Edited)
The cat conv could be clogged, which will strangle the engine.
You might want to look into fixing the other error codes first.


last code that stays on now is the oxygen sensor,im going to try and get the cat off,see where that leads me.would taking the sensor off in front of the cat relieve enough pressure
 
1 - 6 of 6 Posts
Top