Toyota Nation Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
Hi
My MPV has double sun roof. The front one is manual. The rear sun roof glass is fixed whereas the under roof cover moves with a motor. That Cover is stuck in the close position. IT is not moving with the switch mounted on the roof.
Any idea what is the problem. May be the fuse is gone. I am also not aware about its fuse box, as the owner manual was not given to me by the previous owner.
Any help will be highly appreciated
 

·
Registered
Joined
·
202 Posts
First off, can you hear the motor when you push the button? If not, it might be a fuse or the actual switch is bad. If you do hear the motor, the sunroof is stuck. First thing you should try to do is have someone push the button while you try to push the glass back. It will break the sunroof free and it will start working again. If it hasn't been used in a while, this could cause the seal to stick. Another reason (and hopefully this isn't the case), is that your cables are broken. If this is the problem, you are in a world of hurt. These cables can only be ordered throught he dealer and they are expensive. This is a problem that occurs when the sunroof isn't use also. Since the roof runs on an external system, the components are somewhat exposed to the elements. Using the sunroof actually lubes the cable s and other components of the system.
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #3 ·
First off, can you hear the motor when you push the button? If not, it might be a fuse or the actual switch is bad. If you do hear the motor, the sunroof is stuck. First thing you should try to do is have someone push the button while you try to push the glass back. It will break the sunroof free and it will start working again. If it hasn't been used in a while, this could cause the seal to stick. Another reason (and hopefully this isn't the case), is that your cables are broken. If this is the problem, you are in a world of hurt. These cables can only be ordered throught he dealer and they are expensive. This is a problem that occurs when the sunroof isn't use also. Since the roof runs on an external system, the components are somewhat exposed to the elements. Using the sunroof actually lubes the cable s and other components of the system.[/quotery

Thanks a lot Buddy. You were 100% right. It was just struck up. Asked my wife to press the switch wheras i pushed the cover from my hands. After that had greased it properly. Now it is working very nice.
Thanking you again.
Now just looking for a owner manual for 2007 Previa. If someone could give a link from where we can download the same.
Regards
 
1 - 3 of 3 Posts
Top